Package Details: langkit-git r6608.7e98ba83-1

Git Clone URL: https://aur.archlinux.org/langkit-git.git (read-only, click to copy)
Package Base: langkit-git
Description: Compiler for syntactic and semantic language analysis libraries
Upstream URL: https://github.com/AdaCore/langkit/
Licenses: GPL
Conflicts: langkit
Provides: langkit
Submitter: pmderodat
Maintainer: pmderodat
Last Packager: pmderodat
Votes: 1
Popularity: 0.000005
First Submitted: 2018-03-11 11:11
Last Updated: 2020-03-11 10:37

Latest Comments

pmderodat commented on 2020-03-11 10:38

Thanks for the notice! I’ve just added python2-e3-core to the dependencies (many thanks for creating this package) and propagated --build-mode to the installation step. This should work, now.

tfl5034 commented on 2020-03-11 06:46

pmderodat, I just tried installing this package using the latest source from github and I ran into a couple of issues.

  1. There's a new dependency on a group of python modules called e3-core https://github.com/AdaCore/e3-core. I added a package in AUR called python2-e3-core which should work as a dependency (only tested it locally).

  2. The package function needs to be updated to add the flag --build-mode=prod to the install subcommand. Otherwise, it tries to install the dev version. That obviously fails because this package builds the prod version.

pmderodat commented on 2019-06-29 08:22

Hello tfl5034,

Thank you for raising this issue! This, plus several required updates in gnatcoll-iconv and gnatcoll-gmp are now fixed.

tfl5034 commented on 2019-06-27 05:50

I needed to update the PKGBUILD to get this to build. I had to update the flags for scripts/build-langkit_support.py. Instead of --disable-static --enable-shared, I used --library-types relocatable