Package Details: kwinft 5.21.0-1

Git Clone URL: https://aur.archlinux.org/kwinft.git (read-only, click to copy)
Package Base: kwinft
Description: Wayland compositor and X11 window manager
Upstream URL: https://gitlab.com/kwinft/kwinft
Licenses: LGPL
Conflicts: kwin
Provides: kwin
Submitter: abelian424
Maintainer: abelian424
Last Packager: abelian424
Votes: 15
Popularity: 0.70
First Submitted: 2020-07-11 03:54
Last Updated: 2021-02-17 03:19

Required by (50)

Sources (1)

Pinned Comments

aviallon commented on 2021-01-14 22:09

This seriously needs to be in community, awesome drop-in replacement for kwin.

Latest Comments

1 2 Next › Last »

abelian424 commented on 2021-04-13 06:23

@keren_sky I suggest posting the output of dismanctl -i and dismanctl -o, also the names of the processes with high cpu usage

keren_sky commented on 2021-04-12 20:01

Hi, does this need some further configuration after install ? I install this package, then start Plasma + Wayland as per the archlinux wiki. The login period is extended compared w/ an x11 session and everything is slow. Mouse movements, etc. In htop there are four kwin_wayland processes with near 100% CPU usage. Thanks.

edit: I'll reinstall the package and run those commands suggested by abelian424

damentz commented on 2021-02-15 19:51

@abelian424, thanks for reverting back to the latest stable version.

abelian424 commented on 2021-02-15 15:10

@dementz Huge miscalculation on my part. I reverted, but it won't auto-update for those who already installed unless if I put in a goofy non-existent higher version number. Also, need to run pacman -Rdd kdecoration-git for those who already installed, and replace with stable kdecoration. If anyone wants to try the beta, you'll have to edit the PKGBUILD and also install kdecoration-git.

damentz commented on 2021-02-14 17:37

Is there a reason this package and its dependencies randomly began tracking beta branches? KwinFT beta is unusable, so I just had to uninstall it and use alternatives like kwin-lowlatency or kwin beta for 5.21.

It's unfortunate this will be the perception users get with kwinft for a few weeks since the latest stable for version 5.20 is excellent.

undu commented on 2021-02-10 19:25

The current version shouldn't be 5.21.0-1, 5.21.0.beta-0 would work with arch's version numbers and would closely reflect the original version.

I'm unable to compile the package as well:

kwinft-kwinft@5.21.0-beta.0/decorations/decoratedclient.h:87:10: error: ‘void KWin::Decoration::DecoratedClientImpl::requestShowWindowMenu(const QRect&)’ marked ‘override’, but does not override

theriddick commented on 2021-02-05 03:16

@abelian424 I'll try it again sometime later today since now I moved back to non-git version of plasma.

abelian424 commented on 2021-02-05 03:12

theriddick, can you post the dismanctl readout?

theriddick commented on 2021-02-04 07:13

this kwinft doesn't even work for me in X11 or Wayland. Just fails to load completely.

PedroHLC commented on 2021-01-25 13:11

Missing kidletime, kscreenlocker to build in a clean chroot:

CMake Error at /usr/share/cmake-3.19/Modules/FindPackageHandleStandardArgs.cmake:218 (message):
  Could NOT find KF5 (missing: IdleTime) (found suitable version "5.78.0",
  minimum required is "5.74.0")
CMake Error at CMakeLists.txt:123 (find_package):
  Could not find a package configuration file provided by "KScreenLocker"
  with any of the following names