Package Details: kwin-effects-yet-another-magic-lamp 4.1.3.r1c9fc49b-1

Git Clone URL: https://aur.archlinux.org/kwin-effects-yet-another-magic-lamp.git (read-only, click to copy)
Package Base: kwin-effects-yet-another-magic-lamp
Description: Just Yet Another Magic Lamp effect
Upstream URL: https://github.com/zzag/kwin-effects-yet-another-magic-lamp
Licenses: GPL3
Submitter: alevalv
Maintainer: alevalv
Last Packager: alevalv
Votes: 5
Popularity: 0.059467
First Submitted: 2019-01-12 01:26
Last Updated: 2021-02-18 21:01

Latest Comments

cziss commented on 2021-02-20 07:07

Hmm, so thats what it means.. thx :)

alevalv commented on 2021-02-19 21:07

@cziss I'm guessing you are on Manjaro, the new package can only be built against kwin 5.21, so it's marked as kwin>=5.21.0. Hold updating this package until you get plasma 5.21

cziss commented on 2021-02-19 20:22

Hi, it needs kwin-git as dependency now. Why?

michaldybczak commented on 2021-02-19 19:05

Thanks. Now it works :).

alevalv commented on 2021-02-18 21:02

@michaldybczak I bumped the package to the latest commit in the repo that does compile with plasma 5.21.

michaldybczak commented on 2021-02-18 19:22

I just updated to Plasma 5.21 and as usual, the effect doesn't work. I tried to recompile it but get compilation error :(. Probably because kwin was heavily changed in this edition, even re-written anew in some parts?

In file included from /mnt/home-hdd/build/kwin-effects-yet-another-magic-lamp/src/kwin-effects-yet-another-magic-lamp-4.1.3/src/Model.h:24, from /mnt/home-hdd/build/kwin-effects-yet-another-magic-lamp/src/kwin-effects-yet-another-magic-lamp-4.1.3/src/YetAnotherMagicLampEffect.h:21, from /mnt/home-hdd/build/kwin-effects-yet-another-magic-lamp/src/kwin-effects-yet-another-magic-lamp-4.1.3/src/YetAnotherMagicLampEffect.cc:19: /usr/include/kwineffects.h:838:102: note: initializing argument 3 of ‘virtual void KWin::EffectsHandler::prePaintWindow(KWin::EffectWindow, KWin::WindowPrePaintData&, std::chrono::milliseconds)’ 838 | virtual void prePaintWindow(EffectWindow w, WindowPrePaintData& data, std::chrono::milliseconds presentTime) = 0; | ~~~~~~~~~~~~~~~~~~~~~~~~~~^~~~~~~~~~~ make[2]: [src/CMakeFiles/kwin4_effect_yetanothermagiclamp.dir/build.make:143: src/CMakeFiles/kwin4_effect_yetanothermagiclamp.dir/YetAnotherMagicLampEffect.cc.o] Error 1 make[1]: [CMakeFiles/Makefile2:387: src/CMakeFiles/kwin4_effect_yetanothermagiclamp.dir/all] Error 2 make: *** [Makefile:160: all] Error 2 ==> ERROR: There is an error in build(). Aborting...

remaros commented on 2020-02-29 18:26

I think i made a boo-boo. Wrongly flaged.

zzag commented on 2019-02-13 17:35

libkwineffects from KDE Plasma 5.15 is ABI incompatible with the previous version (5.14). Could you please bump pkgrel?