Package Details: kubectl-bin 1.21.0-1

Git Clone URL: https://aur.archlinux.org/kubectl-bin.git (read-only, click to copy)
Package Base: kubectl-bin
Description: Kubernetes.io client binary
Upstream URL: https://kubernetes.io
Licenses: Apache
Conflicts: kubectl, kubernetes>=1.4.6
Provides: kubectl=$pkgver
Submitter: larte
Maintainer: larte
Last Packager: larte
Votes: 85
Popularity: 0.54
First Submitted: 2016-04-26 13:28
Last Updated: 2021-04-10 04:29

Dependencies (0)

Required by (53)

Sources (5)

Latest Comments

« First ‹ Previous 1 2 3 4

larte commented on 2016-08-17 06:05

@armadocerna, can't reproduce, md5sum matches for me ( x86_64 target ). Can you check that the downloaded kubectl binary is as expected?

armandocerna commented on 2016-08-16 15:51

Getting an error validating md5sums for 1.3.5
==> Making package: kubectl-bin 1.3.5-1 (Tue Aug 16 08:49:31 PDT 2016)
==> Retrieving sources...
-> Found kubectl
==> Validating source_x86_64 files with md5sums...
kubectl ... FAILED
==> ERROR: One or more files did not pass the validity check!
:: failed to verify kubectl-bin integrity

armandocerna commented on 2016-08-04 04:22

Getting an error validating md5sums for 1.3.4

:: Checking kubectl-bin integrity...
==> Making package: kubectl-bin 1.3.4-1 (Wed Aug 3 21:20:08 PDT 2016)
==> Retrieving sources...
-> Found kubectl
==> Validating source_x86_64 files with md5sums...
kubectl ... FAILED
==> ERROR: One or more files did not pass the validity check!
:: failed to verify kubectl-bin integrity

larte commented on 2016-08-03 08:49

Updated to 1.3.4

larte commented on 2016-08-03 06:45

Updated to 1.3.2 and added conflict for kubernetes.

gonciarz commented on 2016-07-25 10:18

It's also in conflict with: kubernetes package.

gonciarz commented on 2016-07-25 10:06

A new version is available. You may find the diff below:

diff --git a/PKGBUILD b/PKGBUILD
index d0d4524..05390e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
# Maintainer: larte <lauri.arte@gmail.com>
pkgname=kubectl-bin
pkgdesc="Kubernetes.io client binary"
-pkgver=1.3.0
+pkgver=1.3.2
pkgrel=2
arch=('i686' 'x86_64')
url="http://kubernetes.io"
license=('apache')
source_i686=(http://storage.googleapis.com/kubernetes-release/release/v$pkgver/bin/linux/386/kubectl)
source_x86_64=(http://storage.googleapis.com/kubernetes-release/release/v$pkgver/bin/linux/amd64/kubectl)
-md5sums_i686=('3ac0846e260b931f1e95fe203b4ce5b0')
+md5sums_i686=('1f6d7ece5fb4c8d184b189c936cca2a5')
md5sums_x86_64=('09cdb4e370cb5bc77428550ee5a2cf71')
+md5sums_x86_64=('2e8f3099537db2bc8217eaed9e8718f2')

package() {
install -d "${pkgdir}"/usr/bin/

tkral commented on 2016-07-11 14:02

It would be better to download just kubectl binary, instead of whole 1.3 GB Kubernets archive.
You can find links to kubectl for different architectures in docs: http://kubernetes.io/docs/getting-started-guides/docker/#download-kubectl