Package Details: kubectl-bin 1.21.0-1

Git Clone URL: https://aur.archlinux.org/kubectl-bin.git (read-only, click to copy)
Package Base: kubectl-bin
Description: Kubernetes.io client binary
Upstream URL: https://kubernetes.io
Licenses: Apache
Conflicts: kubectl, kubernetes>=1.4.6
Provides: kubectl=$pkgver
Submitter: larte
Maintainer: larte
Last Packager: larte
Votes: 85
Popularity: 0.54
First Submitted: 2016-04-26 13:28
Last Updated: 2021-04-10 04:29

Dependencies (0)

Required by (53)

Sources (5)

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

larte commented on 2018-11-18 19:04

@bounteous: kubectl-bin does not provide any systemd units. Looks like that's for kubelet, maybe kubelet-bin?

bounteous commented on 2018-11-18 12:28

Systemctl service not working by default

/usr/bin/kubelet --logtostderr=true --v=0 --api-servers=http://127.0.0.1:8080 --address=127.0.0.1 --hostname-override=127.0.0.1 --allow-privileged=false

unknown flag: --api-servers

larte commented on 2018-11-16 18:58

Fixed the mismatch in pkgrel.

dweidenfeld commented on 2018-11-16 09:56

A clean install does not work right now, or is there something I am missing?

:: Installing kubectl-bin package(s)...
:: kubectl-bin package(s) failed to install.
:: ensure package version does not mismatch between .SRCINFO and PKGBUILD
:: ensure package name has a VCS suffix if this is a devel package

larte commented on 2018-11-11 13:57

patch added for aarch64, thanks.

zhaofeng commented on 2018-11-10 19:01

Hi, could you add aarch64 support? The patch is here: https://gist.github.com/zhaofengli/a4fc39ffce13fa355a3bebc8ca598427

This will make my life much easier :)

Precompiled commented on 2018-11-04 02:07

Hi, could you please upgrade the version? Here are the patches https://gist.github.com/cbeneke/45653f5daecea5623f9afebc3aab3e41 :)

oliver.godby commented on 2018-09-10 18:57

Is there any chance that you could update this to 1.11.3, please?

intelfx commented on 2018-08-20 03:36

Please add kubectl to provides= and conflicts=.

I've done this for you, along with a small simplification to package(): http://ix.io/1kJd

Fandekasp commented on 2018-06-29 13:18

kubectl is broken on v1.11.0 https://github.com/kubernetes/kubernetes/issues/65575