Package Details: kubeadm-bin 1.19.3-1

Git Clone URL: https://aur.archlinux.org/kubeadm-bin.git (read-only, click to copy)
Package Base: kubeadm-bin
Description: Kubernetes.io kubeadm binary
Upstream URL: http://kubernetes.io
Licenses: Apache
Conflicts: kubernetes, kubernetes-bin
Provides: kubeadm
Submitter: colemickens
Maintainer: brenix
Last Packager: brenix
Votes: 12
Popularity: 0.97
First Submitted: 2017-07-02 22:47
Last Updated: 2020-10-14 16:57

Dependencies (1)

Required by (0)

Sources (2)

Latest Comments

1 2 Next › Last »

brenix commented on 2020-04-15 01:07

Fixed - thanks @jrd

jrd commented on 2020-04-15 00:21

The line with source+=(https://…) should rather look like:

source+=($pkgname-$pkgver::https://…)

as source destination should be unique (https://wiki.archlinux.org/index.php/PKGBUILD#Sources)

So in the package section, it should rather be:

install -D -m0755 "$pkgname-$pkgver" "${pkgdir}/usr/bin/kubeadm"

grainrigi commented on 2020-03-29 07:02

10-kubeadm.conf should be installed into /usr/lib/systemd/system/kubelet.service.d instead of /etc/systemd/system/kubelet.service.d .

OJFord commented on 2019-12-14 23:11

Generates warnings without ebtables, ethtool, and socat - perhaps they should be added to dependencies?

That said, I can see an argument for not - where do you stop, should a swapoff.service also be included, etc.

houlalajaimal commented on 2019-10-02 08:06

Oups, my mistake. Previous binary version were already downloaded locally.

Thank you very much

brenix commented on 2019-10-02 04:07

Hmm. I've triple-checked and it looks like the SHA256 keeps coming up the same for aarch64 (arm64 binary).

This is the SHA256 that I see, do you have the same? 9a1d21bfb6bd15697ac010665e5917a5364b340d5b60f2f0302c179d75da0f3f

houlalajaimal commented on 2019-10-01 14:03

Hi,

First, thank for maintaining this package. On the latest release, on aarch64 architecture, validation failed for kubadm. Could you set the correct it please? (the same for kubelet-bin)

==> Validating source files with sha256sums... 10-kubeadm.conf ... Passed kubeadm ... FAILED

Thanks,

William

JayceCao commented on 2019-08-08 02:38

I think the package is necessary for those who want to build an entire kubernetes environment with Docker only. For example, me :)

vianney commented on 2019-06-27 06:31

Hi icebal,

Regarding your comment:

since kubernetes-bin now supports armv7l/h, aarch64 and x86_64, does anybody need this package anymore? or should it be removed along with kubelet-bin?

I actually used it and now maintain a PKGBUILD based on yours, for my own use on my own repo. There were three versions released since the last time you updated this PKGBUILD: 1.14.2, 1.14.3 and now 1.15.0. If you need help keeping both kubelet-bin and kubeadm-bin up to date, do not hesitate to say so. I would be happy to help and since I'm already updating this package for myself, it wouldn't be too hard to add a step to push it here too.

edit: plus I just noticed armhf sha256sum was not updated since 1.13.3.

grollinger commented on 2019-01-18 21:01

after installing package version 1.13.0, I get the following output from kubeadm version:

kubeadm version: &version.Info{Major:"1", Minor:"12", GitVersion:"v1.12.2", GitCommit:"17c77c7898218073f14c8d573582e8d2313dc740", GitTreeState:"clean", BuildDate:"2018-10-24T06:51:33Z", GoVersion:"go1.10.4", Compiler:"gc", Platform:"linux/amd64"}

Why version 1.12.2 ?