Package Details: koreader-appimage 2020.07-1

Git Clone URL: https://aur.archlinux.org/koreader-appimage.git (read-only, click to copy)
Package Base: koreader-appimage
Description: An ebook reader supporting PDF, DjVu, EPUB, FB2 and many more formats.
Upstream URL: http://koreader.rocks/
Keywords: djvu ebooks epub fb2 kindle koreader mobi touch
Licenses: AGPL3
Submitter: captn3m0
Maintainer: captn3m0
Last Packager: captn3m0
Votes: 7
Popularity: 0.35
First Submitted: 2018-04-11 20:23
Last Updated: 2020-07-21 11:36

Latest Comments

rafaelff commented on 2019-08-21 09:52

Maintainer, please submit a merge request on the right-side menu to have koreader merged with koreader-bin. See https://wiki.archlinux.org/index.php/AUR_submission_guidelines

yochananmarqos commented on 2019-07-09 15:52

Please correct the pkgdesc according to guidelines. Also, this should be called koreader-bin since it's a binary version.

FabioLolix commented on 2019-07-09 15:37

The program is open source but this pkgbuild repackage the deb binary

rafaelff commented on 2019-06-22 10:39

/startdir/PKGBUILD: line 33: ../koreader.patch: No such file or directory

Currently the PKGBUILD expects "koreader.patch" to be one directory down the $srcdir which is not always true as $startdir, $srcdir and $pkgdir can be in completely different folders. Please include koreader.patch to "depends" array and call it from current working directory, and it should work in any case.

Alternatively, consider simply running sed -i 's/Exec=.*/Exec=/opt/appimages/koreader.AppImage %u/' koreader.desktop to do the same job, and discarding the patch from the git tree.

zoe commented on 2019-03-21 13:34

The right path of the source is :

http://ota.koreader.rocks/koreader-appimage-x86_64-linux-gnu-v$pkgver.AppImage

Nevertheless, shasum256 is right (752250c8279ab205836f81a1380b91866b40d46aaa3d889883cc91a85ac109ea)

speedytux commented on 2019-03-14 12:34

The path of the source folder is wrong

m040601 commented on 2018-11-19 19:14

there is now an appimage stable release, with many improvements on the previous betas, https://github.com/koreader/koreader/releases

ad1217 commented on 2018-08-26 23:17

Seems to need p7zip as a makedepend.