Package Details: kops 1.20.0-0

Git Clone URL: https://aur.archlinux.org/kops.git (read-only, click to copy)
Package Base: kops
Description: Kubernetes Operations - Production Grade K8s Installation, Upgrades, and Management (build from src)
Upstream URL: https://github.com/kubernetes/kops
Licenses: Apache
Submitter: arth
Maintainer: arth
Last Packager: arth
Votes: 4
Popularity: 0.83
First Submitted: 2020-06-30 09:50
Last Updated: 2021-04-16 13:48

Dependencies (2)

Required by (0)

Sources (0)

Latest Comments

1 2 3 Next › Last »

arth commented on 2021-04-16 14:09

Hi! I have added go1.15 package to aur. So I have added makedepends go1.15 to kops PKGBUILD

arth commented on 2021-03-25 10:44

Hi! Kops alpha changes Go version to 1.16.2. I will wait for kops version 1.21 release.

Setting dependency Go <= 1.15 doesn't meet in my system

JanSurft commented on 2021-03-24 10:57

For the time being, the PKGBUILD should be updated so that it also depends on go <= 1.15, shouldn't it?

Or any other solution?

neilg commented on 2021-02-27 17:03

The build issue is related to the Go version: https://github.com/kubernetes/kops/issues/10941#issuecomment-787102601

Downgrading to go 1.15.8 and then upgrading kops worked for me.

neilg commented on 2021-02-27 11:41

I've raised an issue with kops for this. https://github.com/kubernetes/kops/issues/10941

neilg commented on 2021-02-26 11:16

I get the same error when I build manually:

[neil@pinot ~]$ mkdir ~/kops
[neil@pinot ~]$ cd ~/kops
[neil@pinot kops]$ export GOPATH=`pwd`
[neil@pinot kops]$ echo $GOPATH/
/home/neil/kops/
[neil@pinot kops]$ go get -d k8s.io/kops
go: downloading k8s.io/kops v1.19.1
go get: k8s.io/kops@v1.11.0 updating to
    k8s.io/kops@v1.19.1 requires
    k8s.io/kubectl@v0.0.0: reading k8s.io/kubectl/go.mod at revision v0.0.0: unknown revision v0.0.0

arth commented on 2021-02-26 10:04

Hi!

Can you try build it manually?

Documentation: https://kops.sigs.k8s.io/contributing/building/

VLegacy commented on 2021-02-25 16:00

Same issue here.

purist commented on 2021-02-22 23:02

I get the same error as neilg. The go package was recently updated to 1.16, so maybe that's related?

neilg commented on 2021-02-21 16:29

I'm getting a build failure with version 1.19.1-0

==> Making package: kops 1.19.1-0 (Sun 21 Feb 2021 16:22:58 GMT)
==> Retrieving sources...
==> Making package: kops 1.19.1-0 (Sun 21 Feb 2021 16:22:59 GMT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
==> Removing existing $srcdir/ directory...
==> Extracting sources...
==> Sources are ready.
==> Making package: kops 1.19.1-0 (Sun 21 Feb 2021 16:23:01 GMT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Removing existing $pkgdir/ directory...
==> Starting build()...
go: downloading k8s.io/kops v1.19.1
go get: k8s.io/kops@v1.11.0 updating to
    k8s.io/kops@v1.19.1 requires
    k8s.io/kubectl@v0.0.0: reading k8s.io/kubectl/go.mod at revision v0.0.0: unknown revision v0.0.0
==> ERROR: A failure occurred in build().
    Aborting...
error making: kops