Package Details: kodi-tools-texturepacker-devel 18.5pre41-1

Git Clone URL: https://aur.archlinux.org/kodi-devel.git (read-only)
Package Base: kodi-devel
Description: Kodi Texturepacker tool
Upstream URL: https://kodi.tv
Keywords: kodi kodi-devel
Licenses: GPL2
Conflicts: kodi-tools-texturepacker
Provides: kodi-tools-texturepacker=18.5pre41
Submitter: alucryd
Maintainer: MarcinWieczorek (graysky)
Last Packager: graysky
Votes: 33
Popularity: 0.174665
First Submitted: 2014-08-11 23:33
Last Updated: 2019-11-15 01:28

Dependencies (52)

Required by (0)

Sources (51)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

asm0dey commented on 2019-11-08 16:38

Looks like it was my fault. Fixed it and repo is being updated again!

graysky commented on 2019-10-31 20:06

@asm0dey - Builds fine for me.

asm0dey commented on 2019-10-30 11:46

@graysky here you can find the log: https://travis-ci.com/asm0dey/kodi-devel-prebuilt/builds/134180356

Long story short it's

community/waylandpp 0.2.7-1
    Wayland C++ bindings

graysky commented on 2019-10-29 20:33

What's the output of pacman -Ss waylandpp

asm0dey commented on 2019-10-29 17:45

Well, I'm building on latest Arch. Does it offer?

graysky commented on 2019-10-29 17:42

@asm0dey - Does your mirror offer waylandpp>=0.2.7-1? It will not build with earlier versions. Also, how does CI help you in this case?

asm0dey commented on 2019-10-29 06:34

Aaaand… it can't be build again with

==> Error: Could not find all required packages:
    waylandpp>=0.2.7-1 (Wanted by: kodi-devel -> kodi-bin -> kodi-devel)
    waylandpp>=0.2.7-1 (Wanted by: kodi-devel)

Every release breaks its own way :) Thanks god for CI

graysky commented on 2019-10-19 13:35

@asm0dey - I am getting the same... building 18.5pre23-2 which built fine on 16-Oct. I would speculate that one or more of the official packages changed between then and now and is to blame. This also affects building of the 18.4 from [community].

EDIT: https://forum.kodi.tv/showthread.php?tid=348549

asm0dey commented on 2019-10-19 10:49

And build fails again with

[ 91%] Linking CXX static library guilib.a
[ 91%] Built target guilib
Scanning dependencies of target videorenderers_hwdec
[ 91%] Building CXX object build/cores/VideoPlayer/videorenderers/hwdec/CMakeFiles/videorenderers_hwdec.dir/RendererVAAPIGL.cpp.o
In file included from /home/builder/pkg/src/xbmc-18.4-Leia/xbmc/cores/VideoPlayer/VideoRenderers/HwDecRender/RendererVAAPIGL.h:14,
                 from /home/builder/pkg/src/xbmc-18.4-Leia/xbmc/cores/VideoPlayer/VideoRenderers/HwDecRender/RendererVAAPIGL.cpp:9:
/home/builder/pkg/src/xbmc-18.4-Leia/xbmc/cores/VideoPlayer/VideoRenderers/HwDecRender/VaapiEGL.h:38:3: error: ‘PFNGLEGLIMAGETARGETTEXTURE2DOESPROC’ does not name a type; did you mean ‘PFNGLEGLIMAGETARGETTEXTURESTORAGEEXTPROC’?
   38 |   PFNGLEGLIMAGETARGETTEXTURE2DOESPROC glEGLImageTargetTexture2DOES;
      |   ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      |   PFNGLEGLIMAGETARGETTEXTURESTORAGEEXTPROC
/home/builder/pkg/src/xbmc-18.4-Leia/xbmc/cores/VideoPlayer/VideoRenderers/HwDecRender/RendererVAAPIGL.cpp: In member function ‘virtual bool CRendererVAAPI::Configure(const VideoPicture&, float, unsigned int)’:
/home/builder/pkg/src/xbmc-18.4-Leia/xbmc/cores/VideoPlayer/VideoRenderers/HwDecRender/RendererVAAPIGL.cpp:84:13: error: ‘struct VAAPI::InteropInfo’ has no member named ‘glEGLImageTargetTexture2DOES’
   84 |     interop.glEGLImageTargetTexture2DOES = (PFNGLEGLIMAGETARGETTEXTURE2DOESPROC)eglGetProcAddress("glEGLImageTargetTexture2DOES");
      |             ^~~~~~~~~~~~~~~~~~~~~~~~~~~~
/home/builder/pkg/src/xbmc-18.4-Leia/xbmc/cores/VideoPlayer/VideoRenderers/HwDecRender/RendererVAAPIGL.cpp:84:45: error: ‘PFNGLEGLIMAGETARGETTEXTURE2DOESPROC’ was not declared in this scope; did you mean ‘PFNGLEGLIMAGETARGETTEXTURESTORAGEEXTPROC’?
   84 |     interop.glEGLImageTargetTexture2DOES = (PFNGLEGLIMAGETARGETTEXTURE2DOESPROC)eglGetProcAddress("glEGLImageTargetTexture2DOES");
      |                                             ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      |                                             PFNGLEGLIMAGETARGETTEXTURESTORAGEEXTPROC
make[2]: *** [build/cores/VideoPlayer/videorenderers/hwdec/CMakeFiles/videorenderers_hwdec.dir/build.make:63: build/cores/VideoPlayer/videorenderers/hwdec/CMakeFiles/videorenderers_hwdec.dir/RendererVAAPIGL.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:10128: build/cores/VideoPlayer/videorenderers/hwdec/CMakeFiles/videorenderers_hwdec.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 91%] Linking CXX static library videoshaders.a
[ 91%] Built target videoshaders
make: *** [Makefile:141: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...

asm0dey commented on 2019-10-14 13:11

Sorry, lost address: https://github.com/asm0dey/kodi-devel-prebuilt