Package Details: kodi-platform-git r57.e8574b8-1

Git Clone URL: https://aur.archlinux.org/kodi-platform-git.git (read-only, click to copy)
Package Base: kodi-platform-git
Description: Kodi platform support library
Upstream URL: https://github.com/xbmc/kodi-platform
Licenses: GPL
Conflicts: kodi-platform
Provides: kodi-platform
Submitter: Bevan
Maintainer: Bevan
Last Packager: Bevan
Votes: 35
Popularity: 0.000000
First Submitted: 2015-07-25 09:09
Last Updated: 2019-04-27 15:35

Required by (21)

Sources (1)

Latest Comments

« First ‹ Previous 1 2

Bevan commented on 2017-01-09 18:40

@jayki: I'm not sure what the reason for this issue was as I cannot reproduce it. If you set the API level to 99 in the PKGBUILD to get the current git version: there was an outdated dependency. I just fixed this in the PKGBUILD.

If this does not help you, please provide more information on what kodi packages you have installed and if you have changed the API setting in the PKGBUILD.

jayki commented on 2017-01-08 22:47

CMake Error at CMakeLists.txt:8 (find_package):
By not providing "Findkodi.cmake" in CMAKE_MODULE_PATH this project has
asked CMake to find a package configuration file provided by "kodi", but
CMake did not find one.

Could not find a package configuration file provided by "kodi" with any of
the following names:

kodiConfig.cmake
kodi-config.cmake

Add the installation prefix of "kodi" to CMAKE_PREFIX_PATH or set
"kodi_DIR" to a directory containing one of the above files. If "kodi"
provides a separate development package or SDK, be sure it has been
installed.

kevku commented on 2016-10-16 06:52

API=17

17) depends+=('p8-platform') # or libplatform-git
source[0]="${pkgname}::git+https://github.com/xbmc/kodi-platform.git" ;;

zman0900 commented on 2016-02-23 21:02

Since kodi v16 package is available, can the default API for this package change to 16?

Bevan commented on 2016-01-14 14:45

@TheSaint: Do you use the latest version of this PKGBUILD or did you modify it by any way? It should use a git revision which does not look for p8-platform. Also see the comments below.

TheSaint commented on 2016-01-12 19:38

If facing problems during compilation like

"By not providing "Find p8-platform.cmake" in CMAKE_MODULE_PATH this project"

You should change the dependency to libplatform-git instead of libplatform in the PKGBUILD

Bevan commented on 2016-01-09 12:45

Thanks for the hint! Changing the dependency indeed fixes the build of this package but it breaks building all currently available kodi pvr plugins (or at least those I tested). The required changes are still under review. Here some examples:
https://github.com/kodi-pvr/pvr.hts/pull/154
https://github.com/kodi-pvr/pvr.vdr.vnsi/pull/43
https://github.com/kodi-pvr/pvr.vdr.vnsi/pull/49
https://github.com/kodi-pvr/pvr.mythtv/pull/52

For now I therefore changed this package to stick to versions behind the naming change with the intention to change this as soon as the plugins get ready.

This whole thing will become a bit ugly in future. It seems like they want to keep the old version of kodi-platform for Jarvis, meaning that a single version of kodi-platform won't work for stable and git versions for quite some time... Not sure how to handle this, yet. Probably we need some kind of stable version of kodi-platform, but as far as I can see there are no official release tags (which is why I built this package in the first place).

Anonymous comment on 2016-01-09 09:06

Please change dependencies from libplatform to libplatform-git, because platform pkg was renamed with https://github.com/xbmc/kodi-platform/commit/1fdcd0ca6f214efbfd1d7ab66d881abdf5faa24f
package can not be compile with libplatform now