Package Details: kodi-devel-eventclients 19.0b1-3

Git Clone URL: https://aur.archlinux.org/kodi-devel.git (read-only, click to copy)
Package Base: kodi-devel
Description: Kodi Event Clients
Upstream URL: https://kodi.tv
Keywords: kodi kodi-devel
Licenses: GPL2
Conflicts: kodi-eventclients
Provides: kodi-eventclients=19.0b1
Submitter: alucryd
Maintainer: MarcinWieczorek (graysky)
Last Packager: graysky
Votes: 33
Popularity: 0.000087
First Submitted: 2014-08-11 23:33
Last Updated: 2020-11-24 21:09

Dependencies (52)

Required by (0)

Sources (11)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

asm0dey commented on 2020-11-25 19:55

@ghen, I'm sorry, repo will always lag behind a bit. Even if I'll setup cronjob it will still run with some lag.

ghen commented on 2020-11-25 19:43

Found it, pacman -U on a single package caused it ... until the kodi-devel-prebuilt repo was updated and provided the other "missing" package automagically. ;-)

ghen commented on 2020-11-25 19:40

You're right, I must have used an incorrect combination, can't even reproduce it anymore. Thanks for the update!

graysky commented on 2020-11-25 18:49

@ghen - I believe that is expected. Unless you either install one of the bin packages in the same pacman -U ... as the kodi-devel-... package. I created a local repo with the build.

# pacman -S kodi-devel
resolving dependencies...
:: There are 3 providers available for KODI-DEVEL-BIN:
:: Repository local-test
   1) kodi-devel-gbm  2) kodi-devel-wayland  3) kodi-devel-x11

Enter a number (default=1): 3
looking for conflicting packages...
warning: dependency cycle detected:
warning: kodi-devel-x11 will be installed before its kodi-devel dependency

Packages (2) kodi-devel-x11-19.0b1-3  kodi-devel-19.0b1-3

ghen commented on 2020-11-25 17:58

Thanks, however this introduces a new problem; kodi-devel-{x11,wayland,gbm} now provide KODI-DEVEL-BIN instead of KODI-BIN, resulting in:

:: unable to satisfy dependency 'KODI-BIN' required by kodi-devel

graysky commented on 2020-11-24 21:10

@ghen - I see, please try -3 wherein conflicts/provides are tweaked.

asm0dey commented on 2020-11-24 06:56

@ghen, I've pushed the latest revision to repo

ghen commented on 2020-11-23 16:53

Few findings after upgrading: 1/ kodi-devel-x11 doesn't have proper conflicts/provides for kodi-x11 (probably same for wayland and gbm), so you can't upgrade cleanly from kodi to kodi-devel and back. 2/ libplist is in optdepends but is actually required, kodi-x11 is linked to it and can't start without.

asm0dey commented on 2020-11-23 08:52

@ghen, sorry, I'm owner of this repository and I didn't know anybody is interested in it. I'll try to resurrect it.

ghen commented on 2020-11-22 19:52

Hi, would you consider hosting a repository with these packages? The kodi-devel-prebuilt repo mentioned on the wiki is no longer maintained.