Package Details: kodi-addon-pvr-hts-git r803.3993a8a-1

Git Clone URL: https://aur.archlinux.org/kodi-addon-pvr-hts-git.git (read-only, click to copy)
Package Base: kodi-addon-pvr-hts-git
Description: Tvheadend HTSP PVR client addon for Kodi
Upstream URL: https://github.com/kodi-pvr/pvr.hts
Licenses: GPL
Conflicts: kodi-addon-pvr-hts, kodi-pvr-addons
Provides: kodi-addon-pvr-hts
Submitter: Bevan
Maintainer: Bevan
Last Packager: Bevan
Votes: 17
Popularity: 0.002513
First Submitted: 2015-07-25 09:08
Last Updated: 2019-04-27 15:35

Latest Comments

« First ‹ Previous 1 2 3 4 5

Bevan commented on 2015-08-21 13:52

Just stumbled across this recent commit:
https://github.com/xbmc/xbmc/commit/69d18fd5c7772554e16921f7066362bdbfa934ff
and the discussion about it:
https://github.com/xbmc/xbmc/pull/7367

This commit changes exactly the code path that was causing the crash here. So maybe you could try to apply that patch.

Bevan commented on 2015-08-21 13:44

While debugging the issue it suddenly disappeared again. I assume it is related to some specific entries in the EPG, maybe malformed or violating the specification. As soon as the issue reappears I will try to debug it again.
pejobo, is this still an issue for you? I could provide stack traces in an upstream bug report.

Bevan commented on 2015-08-21 09:57

I can actually confirm the issue. I'm currently looking at the stack traces and trying to locate the issue. I'm not sure if it's specific to this addon.

zman0900 commented on 2015-08-21 00:18

My latest working build is r306.9b05d4c-1. That seems to be the newest commit on the Isengard branch, so there must be something else causing your problem. Maybe do a rebuilt to make sure you have the newest version? Maybe something changed in kodi-platform that broke it for you? Maybe it's actually another addon causing the problem?

pejobo commented on 2015-08-20 19:03

Kodi 15.1 core dumps with this package. Also filed also an issue for the kodi package: https://github.com/archlinuxarm/PKGBUILDs/issues/1234

Bevan commented on 2015-08-07 21:15

@Nrm: kodi-platform-git provides kodi-platform. I will change the dependency soon because there is too much confusion about this…

By the way: this is not a reason to flag this out-of-date.

Nrm commented on 2015-08-07 20:36

It seems that kodi-platform build requirement doesn't exist anymore

Bevan commented on 2015-07-25 16:26

Just another quick note: The plugin for the development version of kodi itself would be kodi-devel-pvr-hts, which is also present here on AUR.

Bevan commented on 2015-07-25 16:18

@pejobo: I think the -git suffix is valid. The branch is selectable in the PKGBUILD but it always takes the most current revision in that branch. There seem to be no stable releases or tags unfortunately, otherwise I would have created a non-git package.

Not sure regarding the replace property. It doesn't replace all of kodi-pvr-addons but provides a small part of it. So I think that would be a bit misleading.

Regarding armv7h: Good idea. I will add it after testing at least compilation (probably tomorrow).

pejobo commented on 2015-07-25 16:13

The name is a bit misleading, shouldn't it be simple "kodi-addon-pvr"? Because it's for the now stable kodi v15 / isengard (and not git master). And shouldn't it replace "kodi-pvr-addons" (which was for xbmc v14 / helix and earlier)?
Also adding "armv7h" to arch list would be nice.