Package Details: kodi-addon-pvr-hts-git r803.3993a8a-1

Git Clone URL: https://aur.archlinux.org/kodi-addon-pvr-hts-git.git (read-only, click to copy)
Package Base: kodi-addon-pvr-hts-git
Description: Tvheadend HTSP PVR client addon for Kodi
Upstream URL: https://github.com/kodi-pvr/pvr.hts
Licenses: GPL
Conflicts: kodi-addon-pvr-hts, kodi-pvr-addons
Provides: kodi-addon-pvr-hts
Submitter: Bevan
Maintainer: Bevan
Last Packager: Bevan
Votes: 17
Popularity: 0.002513
First Submitted: 2015-07-25 09:08
Last Updated: 2019-04-27 15:35

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

Bevan commented on 2016-02-19 23:11

@jmason: The tvheadend versions should not matter. It is no dependency for this plugin.

Googling around a bit it seems like you are building the Isengard (Kodi 15) version of this plugin while having Jarvis (Kodi 16) installed. Since you switched between Isengard and Jarvis I imagine something got mixed up.

Please try rebuilding and installing first kodi-platform-git and then this package again and make sure you specify the correct API version in the PKGBUILD of _both_ packages before building them (see instructions in the PKGBUILD).

If it still does not compile please let me know. I will then try your setup using an RPi2 myself. On x86 I can confirm that this package currently builds fine.

jmason commented on 2016-02-19 22:51

I'm finding that building this package on RPi2 with Kodi 15.2 or 16.0-RC3 and https://aur.archlinux.org/packages/tvheadend/ or https://aur.archlinux.org/packages/tvheadend-git/ is failing with the following (no issues with described pre-reqs.):

/home/echo/build/kodi-addon-pvr-hts/src/pvr.hts/src/client.cpp: In function ‘PVR_ERROR GetAddonCapabilities(PVR_ADDON_CAPABILITIES*)’: /home/echo/build/kodi-addon-pvr-hts/src/pvr.hts/src/client.cpp:314:18: error: ‘PVR_ADDON_CAPABILITIES {aka struct PVR_ADDON_CAPABILITIES}’ has no member named bSupportsRecordingFolders’ pCapabilities->bSupportsRecordingFolders = true;
CMakeFiles/pvr.hts.dir/build.make:86: recipe for target 'CMakeFiles/pvr.hts.dir/src/client.cpp.o' failed make[2]:
*** [CMakeFiles/pvr.hts.dir/src/client.cpp.o] Error 1 CMakeFiles/Makefile2:99: recipe for target 'CMakeFiles/pvr.hts.dir/all' failed make[1]:
*** [CMakeFiles/pvr.hts.dir/all] Error 2 Makefile:149: recipe for target 'all' failed make:
*** [all] Error 2 ==> ERROR: A failure occurred in build().
Aborting...

Bevan commented on 2016-02-05 19:55

Since a few days libplatform also is too new for stable kodi versions. Get the current version of the kodi-platform-git PKGBUILD first, which depends on libplatform-legacy instead if you build it for any of the stable kodi versions.
After installing that you will be able to build this package again.

Please also note the instructions in kodi-platform-git's and this package's PKGBUILD.

silent commented on 2016-02-05 19:48

I get the same error as JohnnySSH, but both with libplatform and libplatform-git.

JohnnySSH commented on 2016-01-10 17:14

@Bevan Thank you! With the 'stable' libplatform the HTS plugin compiled perfectly :-)

Bevan commented on 2016-01-10 12:54

@JohnnySSH: I assume you have libplatform-git installed instead of libplatform. There was a naming change of the platform package recently and the kodi plugins are not ready for this change, yet. That's also the reason why kodi-platform-git is stuck to an older version and flagged out of date.

So, currently you need the stable libplatform version to compile kodi plugins.

JohnnySSH commented on 2016-01-10 06:21

Hi, I'm having errors while building:

CMake Error at CMakeLists.txt:9 (find_package):
By not providing "Findplatform.cmake" in CMAKE_MODULE_PATH this project has
asked CMake to find a package configuration file provided by "platform",
but CMake did not find one.

Could not find a package configuration file provided by "platform" with any
of the following names:

platformConfig.cmake
platform-config.cmake

Add the installation prefix of "platform" to CMAKE_PREFIX_PATH or set
"platform_DIR" to a directory containing one of the above files. If
"platform" provides a separate development package or SDK, be sure it has
been installed.


-- Configuring incomplete, errors occurred!


I have these cmake files:

/usr/lib/kodiplatform/kodiplatform-config.cmake
/usr/lib/p8-platform/p8-platform-config.cmake


Kodi Platform version is newly built from git AUR package... as per dependency link above.

Having built this package many times before, could something have changed with Platform??

Anyway, am just after a fix thanks :-)

[EDIT]

looks like kodi-platform-git has been flagged out of date; that might just be the ticket once it gets updates....

planas commented on 2015-09-16 22:52

It works fine for me after applying the aforementioned patch. Hopefully they'll end merging the patch on the 15.x branch

pejobo commented on 2015-08-21 20:27

Ok, it turned out that your finding is correct. So kodi 15.1 and pvr don't go together

pejobo commented on 2015-08-21 14:09

Thank you digging into the issue!
I've got no build chain setup for kodi and don't want to compile on raspberry :/
I went back to kodi 15.0, so it's ok for me now.
I added a question to the discussion on github. If I find some time I'll try to add some value to the discussions. There are some hints at http://forum.kodi.tv/showthread.php?tid=229401 and it looks like the issue you linked is also present in 15.0. But my issue seems to be "15.1 only".