Package Details: kodi-addon-pvr-hts-git r803.3993a8a-1

Git Clone URL: https://aur.archlinux.org/kodi-addon-pvr-hts-git.git (read-only, click to copy)
Package Base: kodi-addon-pvr-hts-git
Description: Tvheadend HTSP PVR client addon for Kodi
Upstream URL: https://github.com/kodi-pvr/pvr.hts
Licenses: GPL
Conflicts: kodi-addon-pvr-hts, kodi-pvr-addons
Provides: kodi-addon-pvr-hts
Submitter: Bevan
Maintainer: Bevan
Last Packager: Bevan
Votes: 17
Popularity: 0.002224
First Submitted: 2015-07-25 09:08
Last Updated: 2019-04-27 15:35

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

crondog commented on 2016-03-05 00:11

@Bevan Everything was working before the upgrade. I always just use the default configuration as tvheadend is on the same box.

Also since you mentioned going into the config, I went into it to look around and then i did not make any changes and then clicked ok. It now works! Why would default settings not just work

Bevan commented on 2016-03-04 23:26

@crondog: Have you configured the add-on accordingly? Similar to where you enable the tvheadend add-on, there is a Configure option where you have to set the address of your tvheadend backend. I'm not sure if this defaults to localhost which would be the correct setting if you run tvheadend on the same machine. And is tvheadend running properly? The kodi add-on just connects to an already running tvheadend backend.
Since you said you updated kodi: did your setup work before that update?

crondog commented on 2016-03-04 22:33

So I just updated to kodi 16.0-2 but am stuck at trying to get this addon to work. With kodi and tvheadend installed and working, I compile and install the following in order: libplatform-legacy, kodi-platform-git then kodi-addon-pvr-hts-git. I then go to Settings->Tv and check enable. Which then takes me to the addons page to enable the tvheadend client. However I never get the tv menu or see the loading of channels. I close and open kodi but when i do it says searching for pvr and then it says that no pvr clients are enabled. Am I doing something wrong?

Bevan commented on 2016-02-25 22:31

@ackalker:
To make it short: If you use the Kodi version from the Arch repos, stick to this package or to kodi-addon-pvr-hts, although I never tested the latter one and it seems to be out-of-date. Don't bother thinking about libplatform. More thorough answer below.

There is no point in adding API versions to the name of this package as it can be used for all versions. You have to set the API level in the PKGBUILD. Creating a separate package for each Kodi version instead would actually flood the AUR with a lot more packages that would constantly have to be added and removed as Kodi development goes on.

There is also no need to decide for a specific libplatform version. kodi-platform-git (a dependency of this package) will depend on the correct version automatically (again: check the API level set in the PKGBUILD before building it).

Apart from this package I see kodi-addon-pvr-hts which sticks to stable versions instead of pulling the most recent one from git, kodi-addon-pvr-hts-rbp-git which seems to specifically target the raspberry-pi (for reasons unknown to me. This package works fine on the raspberry pi, too) and kodi-devel-pvr-hts which belongs to a whole kodi-devel-* series targeting the Kodi development version itself. Again this package will work with the kodi git version, too, if the API level is specified correctly in the PKGBUILD.

Regarding the naming of libplatform-legacy: It's exactly that. It's an outdated version but Kodi decided to stick with it for Jarvis.

All in all not much we can do about the complexity of this whole thing. This package is named -git because it pulls the most recent version from git. That does not mean that other -git packages are the right one to use with this package. But that's what dependencies are for and as far as I can see they are correct. I only can speak for my own packages though.

ackalker commented on 2016-02-25 22:05

I'm sorry to say, but the current package naming scheme is a mess.
Trying to find a mix of deps to build this PVR add-on for the version of Kodi currently in Arch, I have to choose from among:
- community/libplatform (too new)
- kodi-devel-libplatform (too old)
- kodi-devel-platform (also too old)
- kodi-platform-git (the right one, comment says the PKGBUILD should have a variable controlling the API version, but it doesn't, appears to work anyway)
- libplatform-git (likely candidate, but is actually too new)
- libplatform-legacy (the right one, but odd name considering community/kodi is latest stable version)
- etc.

Please consider appending API numbers to package names (like what is done by the gcc* packages in the AUR). When things settle down, please report versioned packages which have become obsolete to the aur-requests mailing list for merging or deletion.

zofiel commented on 2016-02-25 11:00

thanks Bevan, You solved my issue :)

Bevan commented on 2016-02-24 21:13

@zofiel: Please rebuild kodi-platform-git first. This should solve this issue.

zofiel commented on 2016-02-24 21:12

Error with kodi 16:

-- Checking to see if CXX compiler accepts flag -flto - yes
CMake Error at CMakeLists.txt:9 (find_package):
By not providing "Findplatform.cmake" in CMAKE_MODULE_PATH this project has
asked CMake to find a package configuration file provided by "platform",
but CMake did not find one.

Could not find a package configuration file provided by "platform" with any
of the following names:

platformConfig.cmake
platform-config.cmake

Add the installation prefix of "platform" to CMAKE_PREFIX_PATH or set
"platform_DIR" to a directory containing one of the above files. If
"platform" provides a separate development package or SDK, be sure it has
been installed.


-- Configuring incomplete, errors occurred!
See also "/tmp/yaourt-tmp-userssh/aur-kodi-addon-pvr-hts-git/src/kodi-addon-pvr-hts-git/build/CMakeFiles/CMakeOutput.log".
==> ERROR: Se produjo un fallo en build().
Cancelando…
==> ERROR: Makepkg no ha podido compilar kodi-addon-pvr-hts-git.
==> ¿Reiniciar la compilación de kodi-addon-pvr-hts-git? [s/N]
==> ----------------------------------------------------------
==>


Archlinux x86_64

jmason commented on 2016-02-24 04:29

I got around to retrying the install this evening on RPi2. I see you've committed a change setting "API=16" in PKGBUILD for this and the "kodi-platform-git" packages. All ran successfully with Kodi 16.0-RC3 (via "kodi-rbp-git") installed, so that was the problem. I have not tried "API=15" though. Thanks again.

jmason commented on 2016-02-20 01:32

True enough re: no TVHeadEnd dependency. Due to previous problems installing it I ended up getting in the habit of installing it after Kodi and reported it anyway. I re-image the machine to one with a working Kodi (Isengard or Jarvis) and no TVHeadEnd or PVR Plugin installed. So when I’m building the Plugin it is either with Isengard or Jarvis. The two are not being mixed. Once TVHeadEnd is installed I then install the libplatform-legacy and kodi-platform packages, in that order and then on to this one.

The API version in PKGBUILD. This I wasn’t aware of. So “API=“ has to be altered in both kodi-platform-git and kodi-addon-pvr-hts-git to reflect the installed version of Kodi. Good to know and I’ll make a habit to RTFM those PKGBUILD comments in the future.

I’m out of town for a few days and will do that when I get back.

Thanks for the quick turnaround!