Package Details: kmscon-git 2:a-1

Git Clone URL: https://aur.archlinux.org/kmscon-git.git (read-only, click to copy)
Package Base: kmscon-git
Description: Terminal emulator based on Kernel Mode Setting (KMS)
Upstream URL: https://github.com/dvdhrm/kmscon
Licenses: MIT
Conflicts: kmscon
Provides: kmscon
Submitter: thestinger
Maintainer: swiftgeek (nickoe, dvdhrm)
Last Packager: swiftgeek
Votes: 11
Popularity: 0.000000
First Submitted: 2012-06-25 05:37
Last Updated: 2019-08-10 20:07

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

klemmster commented on 2012-12-03 18:33

The docs directory of the current git repository includes a systemd service file. It would be really neat if it would get installed correctly, too.

dvdhrm commented on 2012-11-16 08:53

As a workaround you can pass --disable-wlterm to ./configure

aksr commented on 2012-11-16 08:46

Not sure if it's my fault:
---
CC src/wlterm-wlt_main.o
src/wlt_main.c:37:28: fatal error: wayland-client.h: No such file or directory
compilation terminated.
make[2]: *** [src/wlterm-wlt_main.o] Error 1
make[2]: Leaving directory `/tmp/yaourt-tmp-aksr/aur-kmscon-git/src/kmscon-build'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/yaourt-tmp-aksr/aur-kmscon-git/src/kmscon-build'
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build .
==> Restart building kmscon-git ? [y/N]
==> -----------------------------------
==>

falconindy commented on 2012-10-07 23:45

autogen.sh calls ./configure on its own (which is sort of dirty, imo)... you can just add the --prefix=/usr to ./autogen.sh and ditch the explicit ./configure call.

klemmster commented on 2012-09-29 11:28

works very well for me, thank you

dgbaley27 commented on 2012-09-29 08:37

Latest version works. Very nice, thank you David.

dvdhrm commented on 2012-09-08 14:22

@dgbaley27 Can you try with most recent version again? Also please run as "root", otherwise it will not work.

Anonymous comment on 2012-09-05 05:18

Could you please add libxkbcommon-git to the dependencies?

dgbaley27 commented on 2012-08-24 16:36

What is one way to actually get this started? Can I do some systemd setup to replace some of my VTs with kmscon? Should I be able to just run it from gnome-terminal? No matter what I try, I get: "ERROR: vt: cannot find parent tty"

thestinger commented on 2012-08-18 12:09

@dvdhrm: Thanks, updated :).