Package Details: kiwix-desktop 2.0.4-1

Git Clone URL: https://aur.archlinux.org/kiwix-desktop.git (read-only, click to copy)
Package Base: kiwix-desktop
Description: Offline reader for Web content. It's especially intended to make Wikipedia available offline.
Upstream URL: https://www.kiwix.org/
Keywords: kiwix offline-wikipedia wikipedia
Licenses: GPL3
Conflicts: kiwix-bin
Submitter: nic96
Maintainer: n34r1297
Last Packager: n34r1297
Votes: 44
Popularity: 0.27
First Submitted: 2019-08-12 19:34
Last Updated: 2020-08-05 21:42

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7

Anonymous comment on 2011-07-25 16:19

Hi I get an Error even before the build process:

...
checking for CLucene.h... yes
checking for open in -lclucene... no
configure: error: cannot find clucene

The Problem is I have definitely installed clucene. Is it my fault or is this package not working anymore ?

Anonymous comment on 2011-07-18 10:37

Could you make a new package with Kiwix 0.9 beta1 ?
Here is the dist tgz http://download.kiwix.org/src/nightlies/kiwix-svn-2011-07-15.tar.bz2
Check to add the aria2 dependence...

Anonymous comment on 2011-04-12 13:18

@smradlev @zwirks

The problem is that you try to compile Kiwix against the new xulrunner 2.0.
Currently (and the AUR packages) compiles/runs only against xulrunner 1.9.x.x.

We are working on that. I have open a feature request to track this issue:
http://sourceforge.net/tracker/?func=detail&aid=3285237&group_id=175508&atid=873518

smradlev commented on 2011-04-07 16:12

I get the same error as zwirks.

Anonymous comment on 2011-04-01 06:47

Hi!
It is not working anymore.
build error
""
make[4]: Entering directory `/home/sim/abs/kiwix/src/kiwix-0.9/src/components/xapianAccessor'
/bin/sh ../../../libtool --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H -I. -I../../../src/zimlib/src -I/usr/lib -fshort-wchar -I/usr/include/xulrunner-2.0 -I/usr/include/nspr -march=x86-64 -mtune=generic -O2 -pipe -W -Wall -ansi -pedantic -Wpointer-arith -Wwrite-strings -Wno-long-long -fno-rtti -fPIC -I../../common/ -O6 -MT libXapianAccessor_la-xapianAccessor.lo -MD -MP -MF .deps/libXapianAccessor_la-xapianAccessor.Tpo -c -o libXapianAccessor_la-xapianAccessor.lo `test -f 'xapianAccessor.cpp' || echo './'`xapianAccessor.cpp
libtool: compile: g++ -DHAVE_CONFIG_H -I. -I../../../src/zimlib/src -I/usr/lib -fshort-wchar -I/usr/include/xulrunner-2.0 -I/usr/include/nspr -march=x86-64 -mtune=generic -O2 -pipe -W -Wall -ansi -pedantic -Wpointer-arith -Wwrite-strings -Wno-long-long -fno-rtti -fPIC -I../../common/ -O6 -MT libXapianAccessor_la-xapianAccessor.lo -MD -MP -MF .deps/libXapianAccessor_la-xapianAccessor.Tpo -c xapianAccessor.cpp -fPIC -DPIC -o .libs/libXapianAccessor_la-xapianAccessor.o
xapianAccessor.cpp:2:31: schwerwiegender Fehler: nsIGenericFactory.h: Datei oder Verzeichnis nicht gefunden
Kompilierung beendet.
make[4]: *** [libXapianAccessor_la-xapianAccessor.lo] Fehler 1
make[4]: Leaving directory `/home/sim/abs/kiwix/src/kiwix-0.9/src/components/xapianAccessor'
make[3]: *** [all] Fehler 2
make[3]: Leaving directory `/home/sim/abs/kiwix/src/kiwix-0.9/src/components/xapianAccessor'
make[2]: *** [all-recursive] Fehler 1
make[2]: Leaving directory `/home/sim/abs/kiwix/src/kiwix-0.9/src/components'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/home/sim/abs/kiwix/src/kiwix-0.9/src'
make: *** [all-recursive] Fehler 1
==> FEHLER: Ein Unfall geschah in build().
Breche ab ...
""
I have no clue what is going on - hope it helps to solve the problem (maybe it is not only on my box)
thanks!

Anonymous comment on 2011-01-25 18:58

It works now! Thx a lot.

Anonymous comment on 2011-01-12 13:28

Hi, I'm a Kiwix developer and I have got feedbacks with something like "the Kiwix Arch Package does not work".
By starting kiwix, none of the XPCOM components could be registered.

Unable to register the zimAccessor XPCOM, Kiwix will be unable to read ZIM files.
Unable to register the xapianAccessor XPCOM, Kiwix will be unable to provide the search engine.
Unable to register the zimXapianIndexer XPCOM, Kiwix will be unable to index ZIM files.

I do not know neither Arch nor the Arch Packaging system but I'm interested in fixing the issue.
Maybe we can achieve that together?