Package Details: kiwix-desktop 2.0.4-1

Git Clone URL: https://aur.archlinux.org/kiwix-desktop.git (read-only, click to copy)
Package Base: kiwix-desktop
Description: Offline reader for Web content. It's especially intended to make Wikipedia available offline.
Upstream URL: https://www.kiwix.org/
Keywords: kiwix offline-wikipedia wikipedia
Licenses: GPL3
Conflicts: kiwix-bin
Submitter: nic96
Maintainer: n34r1297
Last Packager: n34r1297
Votes: 44
Popularity: 0.27
First Submitted: 2019-08-12 19:34
Last Updated: 2020-08-05 21:42

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

THS commented on 2017-07-27 16:11

If you want to get the this version working just replace the libz.so.1 with the current one.

sudo ln -sf /usr/lib/libz.so.1 /usr/lib/kiwix/xulrunner/libz.so.1

Now Kiwix is functional again.

nobicycle commented on 2017-07-08 07:53

I confirm the report by
kahredici2 commented on 2017-05-01 00:15

Also confirm the workaround by:
chbinnc commented on 2017-04-23 10:23

Regards

chbinnc commented on 2017-06-02 07:21

I try kiwix-cli-git from https://aur.archlinux.org/packages/kiwix-cli-git/ and it works very well. It uses the new official repository on github https://github.com/kiwix/kiwix.
Tip: You can just start kiwix with `$ kiwix-serve --port=2222 Zimfile1 Zimfile2` and open it with 127.0.0.1:2222 in browser. For other parameters please check --help.

kahredici2 commented on 2017-05-01 00:15

XPCOMGlueLoad error for file /usr/lib/kiwix/xulrunner/libxul.so:

/usr/lib/kiwix/xulrunner/libz.so.1: version `ZLIB_1.2.9' not found (required by /usr/lib/libpng16.so.16)

Couldn't load XPCOM.

chbinnc commented on 2017-04-23 10:23

@anton-tsyganenko I downgrade libpng from 1.6.29 to 1.6.28 and it works, also I tried to directly compile kiwix from source but failed.

anton-tsyganenko commented on 2017-04-16 12:26

I can't run both this package and the executable file from the official website:

XPCOMGlueLoad error for file /usr/lib/kiwix/xulrunner/libxul.so:
/usr/lib/kiwix/xulrunner/libz.so.1: version `ZLIB_1.2.9' not found (required by /usr/lib/libpng16.so.16)
Couldn't load XPCOM.

kralyk commented on 2017-01-07 12:57

@nic96 Thanks for the quick fix!

nic96 commented on 2017-01-07 00:29

I did not originally create this package. I would have never done that, but I guess I never really looked into this PKGBUILD either. It should be fixed now and also kiwix-serve is now also exposed to /usr/bin

kralyk commented on 2017-01-06 18:03

This package sets wrong permissions on /usr/lib/kiwix and /usr/bin/kiwix - those files are writable by everybody. This is a security concern. Please fix the permissions.

Also, could you please expose kiwix-server to /usr/bin as well?

nic96 commented on 2015-02-13 23:13

The md5sum check passes by me.
Maybe retry installing it.