Package Details: kiwix-desktop 2.0.4-1

Git Clone URL: https://aur.archlinux.org/kiwix-desktop.git (read-only, click to copy)
Package Base: kiwix-desktop
Description: Offline reader for Web content. It's especially intended to make Wikipedia available offline.
Upstream URL: https://www.kiwix.org/
Keywords: kiwix offline-wikipedia wikipedia
Licenses: GPL3
Conflicts: kiwix-bin
Submitter: nic96
Maintainer: n34r1297
Last Packager: n34r1297
Votes: 44
Popularity: 0.27
First Submitted: 2019-08-12 19:34
Last Updated: 2020-08-05 21:42

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

greencopper commented on 2019-02-13 23:17

Broken for me too. It cannot load ZIM files.

Getting the error: "Are you sure this is a ZIM file?"

LiptonIceTea commented on 2018-11-30 07:36

Broken for me, very few zim files will actually load. For example, "Unable to load wikipedia_en_all_novid_2018-10.zim. Are you sure this is a ZIM file?". Same for most new zim files.

Also getting segmentation faults whenever I try to index one of the working zim's.

nic96 commented on 2018-09-22 23:19

updated

a216 commented on 2018-09-22 21:50

Any version updates? I think a bugfix for the latest wikipedia zim file opening occurred in August 2018, and I would love to have it for my PC. Thanks!

nic96 commented on 2018-03-03 22:45

@yesday It should be fixed now.

yesday commented on 2018-03-03 21:36

==> Making package: kiwix-bin 0.9-3 (Sat 3 Mar 21:33:54 GMT 2018) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Found kiwix-0.9-linux-x86_64.tar.bz2 -> Found kiwix.desktop ==> Validating source files with md5sums... kiwix-0.9-linux-x86_64.tar.bz2 ... FAILED kiwix.desktop ... Passed ==> ERROR: One or more files did not pass the validity check! :: Unable to build kiwix-bin - makepkg exited with code: 1

Asher256 commented on 2017-10-25 19:12

@nic96: Kiwix works perfectly now! Thank you nic96.

nic96 commented on 2017-10-10 19:18

@Asher256: Done

Asher256 commented on 2017-09-09 15:30

@THS: thanks for the fix.

@to the maintainers 'nic96' and 'felihommen': it could be interesting to add "ln -sf /usr/lib/libz.so.1 /usr/lib/kiwix/xulrunner/libz.so.1" + 'zlib' dependency to the PKGBUILD, to fix the issue reported in the comments permanently (the issue: "/usr/lib/kiwix/xulrunner/libz.so.1: version `ZLIB_1.2.9' not found (required by /usr/lib/libpng16.so.16...").

stardiviner commented on 2017-08-11 01:04

@THS , thanks your workaround. That fix my problem.