Package Details: kimchi 3.0.0-7

Git Clone URL: https://aur.archlinux.org/kimchi.git (read-only, click to copy)
Package Base: kimchi
Description: KVM management plugin for WoK.
Upstream URL: https://github.com/kimchi-project/kimchi
Keywords: kimchi-project
Licenses: LGPL, Apache
Groups: kimchi-project
Conflicts: kimchi-git
Submitter: disconnect
Maintainer: None
Last Packager: samip537
Votes: 12
Popularity: 0.004846
First Submitted: 2014-01-29 21:54
Last Updated: 2020-09-29 05:01

Latest Comments

1 2 3 4 5 Next › Last »

broeman commented on 2020-03-22 15:29

FYI the dependency python-ipaddr is now called python-ipaddress for python3. edit: apparently it is also an issue they work on in the project: https://github.com/kimchi-project/kimchi/issues/1298

samip537 commented on 2020-02-07 07:41

It seems to build now. Let me know if you are able to use it. @nac

nac commented on 2020-02-05 18:24

Also getting the following error:

Traceback (most recent call last):
  File "/bin/wokd", line 30, in <module>
    import wok.server
  File "/usr/lib/python3.8/site-packages/wok/server.py", line 35, in <module>
    from wok.proxy import check_proxy_config
  File "/usr/lib/python3.8/site-packages/wok/proxy.py", line 27, in <module>
    from wok import sslcert
  File "/usr/lib/python3.8/site-packages/wok/sslcert.py", line 27, in <module>
    from OpenSSL import crypto
ModuleNotFoundError: No module named 'OpenSSL'

I think extra/python-pyopenssl is required.

nac commented on 2020-02-05 18:20

Please make this package depend on spice-html5 instead of spirce-html5-git

samip537 commented on 2020-02-01 21:28

Adopted, and updated.

brando56894 commented on 2020-01-24 15:49

I'm not going to maintain this, so I'm not adopting it, but here's an updated PKGBUILD for kimchi v3.0: https://pastebin.com/1hhuzNRi

You need to use my updated wokd PKGBUILD first: https://pastebin.com/vTBMantZ

It may complain about a few packages not being available, even though they definitely exist in the AUR, just install them manually.

samip537 commented on 2020-01-17 09:52

Maintainer, please update this to Wok 3.0 and latest kimchi which depends on Python 3.

vkm commented on 2018-12-13 12:04

wokd.service not started Traceback (most recent call last): File "/usr/bin/wokd", line 30, in <module> import wok.server File "/usr/lib/python2.7/site-packages/wok/server.py", line 28, in <module> from wok import auth, config, websocket File "/usr/lib/python2.7/site-packages/wok/websocket.py", line 28, in <module> from websockify import WebSocketProxy ImportError: No module named websockify

websockify I get from https://aur.archlinux.org/packages/websockify/

chr0mag commented on 2018-10-20 01:57

There hasn't been a new release from upstream in over a year. Disowning.

chr0mag commented on 2018-08-07 01:08

That's an issue with the spice-html5 dependency package and has already been reported here: https://aur.archlinux.org/packages/spice-html5/ .