Package Details: kiconedit 4.4.0-5

Git Clone URL: https://aur.archlinux.org/kiconedit.git (read-only, click to copy)
Package Base: kiconedit
Description: KDE icon editor
Upstream URL: http://www.kde.org/applications/graphics/kiconedit
Licenses: GPL2
Submitter: ilpianista
Maintainer: willemw
Last Packager: willemw
Votes: 10
Popularity: 0.000092
First Submitted: 2010-09-25 08:49
Last Updated: 2015-06-09 08:22

Dependencies (4)

Required by (0)

Sources (1)

Latest Comments

d_fajardo commented on 2020-07-06 22:58

Yes the error is coming from building kdebase-runtime. I'll see if I can fix the issue there first.

willemw commented on 2020-07-04 05:26

I don't get any errors building kiconedit. There is no reference to either servicemodel.cpp or kdnssd in the kiconedit source files. I think the problem is in one of the dependencies.

File servicemodel.h is owned by kdelibs, a dependency of kdebase-runtime. There is a dnssd/servicemodel.cpp file in the kdelibs source files.

If you try to build and install the kdelibs and kdebase-runtime dependencies now, it won't build. Maybe because of the recent switch to GCC 10?

d_fajardo commented on 2020-07-03 21:03

I'm getting this error installing this:

make[2]: [dnssd/CMakeFiles/kdnssd.dir/build.make:151: dnssd/CMakeFiles/kdnssd.dir/servicemodel.cpp.o] Error 1 make[1]: [CMakeFiles/Makefile2:28451: dnssd/CMakeFiles/kdnssd.dir/all] Error 2 make: *** [Makefile:183: all] Error 2

Any help?

Anonymous comment on 2010-12-06 22:25

I am a robot. This is not an official message. AUR guidelines suggest to not include binaries. Examples:
kiconedit/kiconedit-svn20101021.tar.xz
Feel free to disregard this as you would any other comment. This robot will not post here again.

ilpianista commented on 2010-09-25 08:50

* moved from [community]