Package Details: kicad-nightly-bin 202109180406+34c2bd58d1-1

Git Clone URL: https://aur.archlinux.org/kicad-nightly-bin.git (read-only, click to copy)
Package Base: kicad-nightly-bin
Description: Electronic schematic and printed circuit board (PCB) design tools
Upstream URL: http://kicad-pcb.org/
Licenses: GPLv3
Conflicts: kicad-nightly
Provides: kicad-nightly
Submitter: amakovec
Maintainer: amakovec
Last Packager: amakovec
Votes: 0
Popularity: 0.000000
First Submitted: 2021-07-06 06:04
Last Updated: 2021-09-18 06:24

Pinned Comments

amakovec commented on 2021-07-06 15:08

Ubuntu has not yet released glew-2.2 to their repos, so Ubuntu's builds of kicad-nightly are currently compiled with glew-2.1. The glew-2.1 dependency will be removed from this AUR package once Ubuntu releases glew-2.2.

amakovec commented on 2021-07-06 15:05

As @DX-MON reported on kicad-nightly, please downgrade python-wxpython to 4.0.7.2-5 for now. For kicad-nightly-bin, the issue seems to be that Ubuntu's builds of kicad-nightly use a version of GCC with C++ ABI 1014, whereas Arch's builds of python-wxpython migrated to C++ ABI 1016 after version 4.0.7.2-5.

Latest Comments

amakovec commented on 2021-09-12 21:14

Package was broken from 202109040414+a397e85589-1 to 202109120408+9c78e4cf54-1, due to Arch's glibc being behind Ubuntu 21.10's (2.33 vs 2.34). This is now fixed in version 202109120410+9c78e4cf54-1, where the PKGBUILD has been modified to use the Ubuntu 21.04 build as a base.

amakovec commented on 2021-07-06 15:08

Ubuntu has not yet released glew-2.2 to their repos, so Ubuntu's builds of kicad-nightly are currently compiled with glew-2.1. The glew-2.1 dependency will be removed from this AUR package once Ubuntu releases glew-2.2.

amakovec commented on 2021-07-06 15:05

As @DX-MON reported on kicad-nightly, please downgrade python-wxpython to 4.0.7.2-5 for now. For kicad-nightly-bin, the issue seems to be that Ubuntu's builds of kicad-nightly use a version of GCC with C++ ABI 1014, whereas Arch's builds of python-wxpython migrated to C++ ABI 1016 after version 4.0.7.2-5.