Package Details: kicad-git 5.99.0.r6895.gbd63c018c9-1

Git Clone URL: https://aur.archlinux.org/kicad-git.git (read-only, click to copy)
Package Base: kicad-git
Description: Electronic schematic and printed circuit board (PCB) design tools
Upstream URL: http://kicad-pcb.org/
Licenses: GPL
Conflicts: kicad, kicad-bzr
Provides: kicad
Submitter: Chocobo
Maintainer: nickoe
Last Packager: nickoe
Votes: 67
Popularity: 0.90
First Submitted: 2015-10-08 16:39
Last Updated: 2020-11-09 19:28

Pinned Comments

nickoe commented on 2021-05-23 11:09

@haawda, thank you for testing, but I currently think the right thing to do is to get community/python-wxpython downgraded.

See https://bugs.archlinux.org/task/70908

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

nickoe commented on 2019-06-14 14:36

@dale6998 works fine for me. Maybe you have some permission issues on your filesystem?

dale6998 commented on 2019-06-14 12:26

Have you guys seen this error?

-- Installing: /tmp/yaourt-tmp-dale/aur-kicad-git/pkg/kicad-git/usr/bin/pcb_calculator
CMake Error at pcb_calculator/cmake_install.cmake:47 (file):
  file INSTALL cannot copy file
  "/tmp/yaourt-tmp-dale/aur-kicad-git/src/kicad-git/build/pcb_calculator/pcb_calculator"
  to
  "/tmp/yaourt-tmp-dale/aur-kicad-git/pkg/kicad-git/usr/bin/pcb_calculator".
Call Stack (most recent call first):
  cmake_install.cmake:76 (include)


make: *** [Makefile:74: install] Error 1

doragasu commented on 2019-05-19 09:42

I have the same problem as @dale6998 when using the privative NVIDIA drivers. If I switch to nouveau, or use my laptop with Intel graphics card, everything works.

nickoe commented on 2019-05-17 14:22

Are you sure your system is updated? Maybe you updsted your graphics driver recently and may need to restart your machine.

dale6998 commented on 2019-05-17 12:22

package builds and installs, but my menus are broken and running the 3D viewer crashes KiCad...Any idea where to start looking?

nickoe commented on 2019-03-01 21:51

glm master is fixed, so I uploaded glm-git to be able to use gcc again.

You may need to clear your build dir.

niqingliang2003 commented on 2019-02-24 13:31

@nickoe: today.

kicad-footprints-git r3136.e1d4ff85-1

kicad-git r12427.c4fe6785a-1

kicad-packages3d-git r2019.02.16.4a0375d-1

kicad-symbols-git r4469.2063c030-1

nickoe commented on 2019-02-24 12:55

@niqingliang2003, when did you rebuild the kicad-git package?

Also, what version do you have installed?

niqingliang2003 commented on 2019-02-24 12:43

I updated the system today:

python-wxpython 4.0.4-5

wxgtk-common 3.0.4-2

wxgtk3 3.0.4-2

nickoe commented on 2019-02-24 12:30

@niqingliang2003, I still don't think it is a problem with this package. Please check your dependencies, expecially the wxgtk3 and python-wxpython.