Package Details: kicad-git 5.99.0.r6895.gbd63c018c9-1

Git Clone URL: https://aur.archlinux.org/kicad-git.git (read-only, click to copy)
Package Base: kicad-git
Description: Electronic schematic and printed circuit board (PCB) design tools
Upstream URL: http://kicad-pcb.org/
Licenses: GPL
Conflicts: kicad, kicad-bzr
Provides: kicad
Submitter: Chocobo
Maintainer: nickoe
Last Packager: nickoe
Votes: 67
Popularity: 0.96
First Submitted: 2015-10-08 16:39
Last Updated: 2020-11-09 19:28

Pinned Comments

nickoe commented on 2021-05-23 11:09

@haawda, thank you for testing, but I currently think the right thing to do is to get community/python-wxpython downgraded.

See https://bugs.archlinux.org/task/70908

Latest Comments

« First ‹ Previous ... 21 22 23 24 25 26

MrBlister commented on 2012-04-11 19:45

As of BZR-3495 this no longer builds. Error message:

"You must use '--with-gnomeprint' or '--with-gtkprint' in your wx library configuration."

wxgtk (2.8) in the extra repo is not built with either of these, but wxgtk-2.9 in AUR is built with '--with-gnomeprint'. However, wxgtk-2.9 does not provide "wxwidgets" and kicad-bzr fails to build with this installed and wxgtk (2.8) temporarily uninstalled.

queueRAM commented on 2012-03-22 00:18

My bad. Fixed.

djgera commented on 2012-03-22 00:10

infinite loop in kicad.install:

pre_remove() {
pre_remove $1
}

Anonymous comment on 2011-04-30 04:14

The bzr checkout really takes forever with this. Could "--lightweight" be added to the "bzr co" line, so that won't spend forever getting all the old revisions that won't even be used in the build.

queueRAM commented on 2011-04-12 05:22

Thanks for the notification. JPC added this in revno 2955 2011-04-09 with the following commit message:
CMake: add definition KICAD_TESTING_VERSION and KICAD_STABLE_VERSION.
One of these 2 options *must* be now defined (i.e. run cmake with option -DKICAD_STABLE_VERSION or -DKICAD_TESTING_VERSION

CMAKE_BUILD_TYPE is actually still valid since it is part of the CMake build system.

Anonymous comment on 2011-04-12 00:00

I just tried updating kicad-bzr to revision 2958 .. unfortunately it doesn't compile anymore using the PKGBUILD.

This is the error message:
Please set to ON one option of KICAD_TESTING_VERSION or KICAD_STABLE_VERSION
When calling cmake add option -DKICAD_STABLE_VERSION=ON
or add option -DKICAD_TESTING_VERSION=ON
CMake Error at CMakeLists.txt:61 (message):
one option of KICAD_TESTING_VERSION or KICAD_STABLE_VERSION must be defined

I've been able to fix this with: http://sprunge.us/KbXd
That PKGBUILD still uses -DCMAKE_BUILD_TYPE=Release which probably is not used anymore.

Thanks,

Fabio

Anonymous comment on 2011-01-19 21:49

Hey dude, thanks for maintaining this PKGBUILD! Working great here! I'm getting addicted to KiCAD! Thanks!!!

queueRAM commented on 2010-07-24 06:04

Split off kicad-doc-bzr and kicad-library-bzr into their own packages which kicad and kicad-bzr now optdepend on. Please install these to maintain the current kicad package functionality.

queueRAM commented on 2010-07-21 15:44

Looks like i should pay more attention to 'man PKGBUILD'. You are indeed correct. Thanks Chocobo!

Chocobo commented on 2010-07-21 13:14

If you replace _bzrbranch with _bzrtrunk the package auto-increment will work.