Package Details: kicad-git 5.99.0.r6895.gbd63c018c9-1

Git Clone URL: https://aur.archlinux.org/kicad-git.git (read-only, click to copy)
Package Base: kicad-git
Description: Electronic schematic and printed circuit board (PCB) design tools
Upstream URL: http://kicad-pcb.org/
Licenses: GPL
Conflicts: kicad, kicad-bzr
Provides: kicad
Submitter: Chocobo
Maintainer: nickoe
Last Packager: nickoe
Votes: 67
Popularity: 0.96
First Submitted: 2015-10-08 16:39
Last Updated: 2020-11-09 19:28

Pinned Comments

nickoe commented on 2021-05-23 11:09

@haawda, thank you for testing, but I currently think the right thing to do is to get community/python-wxpython downgraded.

See https://bugs.archlinux.org/task/70908

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

nickoe commented on 2020-10-22 18:36

@StefanH What offical way?

Why do you want a tilde and dot?

StefanH commented on 2020-10-22 17:27

Hi Nick! Could you update the pkgver function to:

git describe | sed -r 's/([^-]+)-([^-]+)-([^-]+)/\1~\2.\3/'

as per the official way to get the latest version? The sed command I added to translate the dashes to something fitting the Arch version string format. Source: https://gitlab.com/kicad/code/kicad/-/issues/6114#note_434166499

nickoe commented on 2020-07-20 17:43

@firewalker, this is a strange error. This is not an issue for me, and I also tried to update my system.

First off it looks like there is some issue with it finding wxpython 3.0.2 instead of 4.0.7. Is your default python python2?

orson commented on 2020-05-26 08:36

Hi Salamandar,

In such case, should not libjpeg-turbo be added as a dependency in libfreeimage?

Salamandar commented on 2020-05-26 07:56

Hi, could you add the dependency libjpeg-turbo ? Without it, I get /usr/bin/ld : /usr/lib/libfreeimage.so.3 : undefined reference to « jpeg_read_icc_profile@LIBJPEG_8.0 »

moritz commented on 2020-01-20 21:30

as KiCad moved from launchpad to GitLab, the source should be: git+https://gitlab.com/kicad/code/kicad.git

moritz commented on 2019-12-05 10:27

Does anybody has a clue why it is not building and how to investigate this?

Scanning dependencies of target kicad
[ 62%] Building CXX object kicad/CMakeFiles/kicad.dir/dialogs/dialog_template_selector_base.cpp.o
/home/user/trizen-user/kicad-git/src/kicad-git/pcbnew/netlist_reader/kicad_netlist_reader.cpp: In member function ‘void KICAD_NETLIST_PARSER::parseNet( )’:
/home/user/trizen-user/kicad-git/src/kicad-git/pcbnew/netlist_reader/kicad_netlist_reader.cpp:244:22: error: ‘T_pinfunction’ was not declared in this s cope; did you mean ‘pin_function’?
244 | case T_pinfunction:
| ^~~~~~~~~~~~~
| pin_function
make[2]: [common/CMakeFiles/pcbcommon.dir/build.make:592: common/CMakeFiles/pcbcommon.dir/__/pcbnew/netlist_reader/kicad_netlist_reader.cpp.o] Error 1
make[2]:
Waiting for unfinished jobs....
[ 62%] Building CXX object common/CMakeFiles/pcbcommon.dir/__/pcbnew/kicad_plugin.cpp.o
[ 62%] Building CXX object kicad/CMakeFiles/kicad.dir/dialogs/dialog_template_selector.cpp.o
[ 62%] Linking CXX shared module libs3d_plugin_idf.so
[ 62%] Built target s3d_plugin_idf

[ 64%] Built target eeschema_kiface
make: *** [Makefile:163: all] Error 2
==> ERROR: A failure occurred in build().
Aborting..

And how to proper formate postings here?

nickoe commented on 2019-11-05 10:14

@balajiTn, it does not look like you have the real error there. Maybe post the complete output in a pastebin?

balajiTn commented on 2019-10-31 11:06

My build is failing and I am finding it difficult to spot the error. Could you please help me?

-----------------------Output from terminal-----------------------

[ 80%] Built target pcbnew
Scanning dependencies of target pcbnew_python_module

[ 81%] Creating python's pcbnew native module _pcbnew.so for command line use.
Error copying file "_pcbnew.kiface" to "_pcbnew.so".

make[2]: *** [pcbnew/CMakeFiles/pcbnew_python_module.dir/build.make:61:   pcbnew/_pcbnew.so] Error 1

make[2]: *** Deleting file 'pcbnew/_pcbnew.so'

make[1]: *** [CMakeFiles/Makefile2:1149: pcbnew/CMakeFiles   /pcbnew_python_module.dir/all] Error 2

make: *** [Makefile:163: all] Error 2

==> ERROR: A failure occurred in build().

Aborting...

==> ERROR: Makepkg was unable to build kicad-git.

e7p commented on 2019-07-04 13:47

@dale6998 @nickoe it seems that at the very last step usually /tmp runs full. a solution would be to increase the size of the tmpfs to more than 8 GB. Another option would be to use a different directory for building.