Package Details: keyleds-git r264.4219bcf-1

Git Clone URL: https://aur.archlinux.org/keyleds-git.git (read-only)
Package Base: keyleds-git
Description: Advanced RGB LED driver/controller for G410, G513, G610, G810, G910 and GPro
Upstream URL: https://github.com/spectras/keyleds
Licenses: GPL3
Conflicts: keyleds
Submitter: jtyr
Maintainer: jtyr
Last Packager: jtyr
Votes: 0
Popularity: 0.000000
First Submitted: 2019-02-24 11:06
Last Updated: 2019-02-24 11:06

Latest Comments

txtsd commented on 2019-11-01 17:36

==> Making package: keyleds-git r264.4219bcf-1 (Fri 01 Nov 2019 11:05:55 PM IST)
==> Retrieving sources...
  -> Updating keyleds git repo...
Fetching origin
remote: Enumerating objects: 5, done.
remote: Counting objects: 100% (5/5), done.
remote: Compressing objects: 100% (5/5), done.
remote: Total 5 (delta 0), reused 0 (delta 0), pack-reused 0
Unpacking objects: 100% (5/5), done.
From https://github.com/spectras/keyleds
 * [new ref]         refs/pull/43/head  -> refs/pull/43/head
 * [new ref]         refs/pull/43/merge -> refs/pull/43/merge
==> Validating source files with sha256sums...
    keyleds ... Skipped
==> Cleaning up...
==> WARNING: PACKAGER should have the format 'Example Name <email@address.invalid>'
==> Making package: keyleds-git r264.4219bcf-1 (Fri 01 Nov 2019 11:06:00 PM IST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating keyleds git repo...
Fetching origin
==> Validating source files with sha256sums...
    keyleds ... Skipped
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Creating working copy of keyleds git repo...
Cloning into 'keyleds'...
done.
==> Starting pkgver()...
==> ERROR: pkgver is not allowed to contain colons, forward slashes, hyphens or whitespace.
==> ERROR: pkgver() generated an invalid version:   -> Getting version
r290.4917e04
Error making: keyleds-git

casben79 commented on 2019-03-19 02:20

@jtyr this has been resolved by the author on github.

https://github.com/keyleds/keyleds/issues/35

Thanks for your help.

jtyr commented on 2019-03-18 23:17

It compiles just fine for me. Please let me know if you find out which dependency is missing.

casben79 commented on 2019-03-18 22:32

I'm getting the following error when trying to build this package.

[ 83%] Building CXX object keyledsd/CMakeFiles/keyledsd.dir/src/service/dbus/DeviceManager.cxx.o
/homedir/.cache/pacaur/keyleds/src/keyleds-1.0.0/keyledsd/src/service/dbus/DeviceManager.cxx:140:1: error: missing initializer for member ‘sd_bus_vtable::<unnamed union>::<unnamed struct>::features’ [-Werror=missing-field-initializers]

Is there something i'm missing?