Package Details: keepassxc-git 2.5.2.r17.g8ded3bdb-1

Git Clone URL: https://aur.archlinux.org/keepassxc-git.git (read-only, click to copy)
Package Base: keepassxc-git
Description: Cross-platform community-driven port of KeePass Password Safe
Upstream URL: https://github.com/keepassxreboot/keepassxc
Keywords: keepassxc password security
Licenses: GPL2
Conflicts: keepassxc
Provides: org.freedesktop.secrets
Replaces: keepassx-http, keepassx-reboot-git
Submitter: dlandau
Maintainer: dlandau (phoerious)
Last Packager: phoerious
Votes: 59
Popularity: 0.77
First Submitted: 2016-11-09 12:41
Last Updated: 2020-01-04 15:16

Required by (17)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

Hideaki commented on 2016-04-06 18:35

eugenesan isn't maintaining this fork anymore. There's a new repo we should probably following: https://github.com/droidmonkey/keepassx_http


Here's a modified PKGBUILD:

pkgname=keepassx-http
_gitname=keepassx_http
pkgver=2.0.2
pkgrel=1
pkgdesc="KeepassX, with eugenesan's merge request for keepasshttp."
arch=('i686' 'x86_64')
url="https://github.com/droidmonkey/keepassx_http"
license=('GPL2')
depends=('libxtst' 'shared-mime-info' 'qjson' 'libmicrohttpd' 'oath-toolkit')
install=keepassx.install
makedepends=('git' 'intltool' 'cmake' 'qt5-base' 'qt5-tools' 'zlib' 'libgcrypt')
conflicts=('keepassx-svn' 'keepassx' 'keepassx2-git' 'keepassx2' 'keepassx2-yubikey-git' 'keepassx-http' 'keepassx-git')
options=(!emptydirs)
source=(git+https://github.com/droidmonkey/keepassx_http)
md5sums=('SKIP')

pkgver() {
cd "${_gitname}"
git describe --long | sed 's/^FOO-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}

build() {
cd "${_gitname}"
cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_BINDIR=/usr/bin -DCMAKE_INSTALL_LIBDIR=/usr/lib -DCMAKE_VERBOSE_MAKEFILE=OFF -DWITH_GUI_TESTS=ON
make
}

package() {
cd "${_gitname}"
make PREFIX=/usr DESTDIR="${pkgdir}" install
}

davidosomething commented on 2016-02-09 03:28

note for anyone using pacaur
don't use pacaur
too many issues
just `cower -d` and `makepkg -sri`

maxqia commented on 2016-01-10 19:30

Updated

janoliver commented on 2016-01-07 18:09

Please add oath-toolkit to the dependencies and remove -beta from the git branch, as the stable 2.0 version is released now.

maxqia commented on 2015-11-15 06:24

Fixed

vith commented on 2015-11-15 05:49

`vercmp 2.0.r1-1 2.0.alpha6.r214.g8b6d49a-1` returns 1, meaning the first arg is a newer version than the second arg, as it should. Please update the PKGBUILD and .SRCINFO with the correct version number. `makepkg -f && mksrcinfo` should do it automatically.

anonchique commented on 2015-11-14 21:16

same issue, always reinstalls.

vith commented on 2015-11-14 08:30

pacaur always thinks this package needs to be upgraded. Is it because the pkgver() function doesn't match the pkgver field?

log: https://gist.github.com/vith/f56ff4fa41d9331ad084

maxqia commented on 2015-11-13 06:32

Updated

Blissfull commented on 2015-11-10 16:28

The branch 2.0-http-totp-beta2 seems to be the most up to date, it might be advisable to switch to it.