Package Details: keepassxc-git 2.5.2.r17.g8ded3bdb-1

Git Clone URL: https://aur.archlinux.org/keepassxc-git.git (read-only, click to copy)
Package Base: keepassxc-git
Description: Cross-platform community-driven port of KeePass Password Safe
Upstream URL: https://github.com/keepassxreboot/keepassxc
Keywords: keepassxc password security
Licenses: GPL2
Conflicts: keepassxc
Provides: org.freedesktop.secrets
Replaces: keepassx-http, keepassx-reboot-git
Submitter: dlandau
Maintainer: dlandau (phoerious)
Last Packager: phoerious
Votes: 59
Popularity: 0.79
First Submitted: 2016-11-09 12:41
Last Updated: 2020-01-04 15:16

Required by (17)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

dlandau commented on 2017-06-29 09:01

Both of those are transitive dependencies so no need to add them, and to everyone: please don't mark a -git package as out of date because of new upstream releases. The package fetches the latest code from git on build time regardless of what string happens to be in the version field.

You can update devel packages e.g. with

$ yaourt -Su --devel

jamietanna commented on 2017-06-25 14:54

This needs to be updated to pull the following dependencies in:
- extra/pcre2
- extra/double-conversion

SammysHP commented on 2017-06-14 08:05

Why does this conflict with so many keepass alternatives? It should only conflict with "keepassxc".

Also it provides many packages that are definitely not provided, like "keepassx" (the 1.x branch) and "keepassx2" (the original version of keepassxc) and their git versions.

yan12125 commented on 2017-06-02 08:33

Hello, the fix `sed -i'' -e 's/add_subdirectory(x11)/add_subdirectory(xcb)/' src/autotype/CMakeLists.txt` is no longer necessary - it's already fixed upstream in https://github.com/keepassxreboot/keepassxc/commit/e011a6eb2524c6e901ddff4b1928842273f78c87. Could you remove that?

widowild commented on 2017-04-10 21:27

2.1.4 https://github.com/keepassxreboot/keepassxc/blob/develop/CHANGELOG

- Bumped KeePassHTTP version to 1.8.4.2
- KeePassHTTP confirmation window comes to foreground [#466]

dummys commented on 2017-04-03 07:12

fixed with the latest version, thx

dummys commented on 2017-03-19 20:49

Error on the latest version:

[ 31%] Building CXX object src/http/CMakeFiles/keepasshttp.dir/OptionDialog.cpp.o
/home/dummys/build/cower/keepassxc-git/src/keepassxc/src/http/OptionDialog.cpp: In constructor ‘OptionDialog::OptionDialog(QWidget*)’:
/home/dummys/build/cower/keepassxc-git/src/keepassxc/src/http/OptionDialog.cpp:30:11: error: ‘class Ui::OptionDialog’ has no member named ‘warningWidget’; did you mean ‘tabWidget’?
m_ui->warningWidget->showMessage(tr("The following options can be dangerous!\nChange them only if you know what you are doing."), MessageWidget::Warning);
^~~~~~~~~~~~~
/home/dummys/build/cower/keepassxc-git/src/keepassxc/src/http/OptionDialog.cpp:30:135: error: ‘MessageWidget’ has not been declared
e(tr("The following options can be dangerous!\nChange them only if you know what you are doing."), MessageWidget::Warning);
^~~~~~~~~~~~~
/home/dummys/build/cower/keepassxc-git/src/keepassxc/src/http/OptionDialog.cpp:31:11: error: ‘class Ui::OptionDialog’ has no member named ‘warningWidget’; did you mean ‘tabWidget’?
m_ui->warningWidget->setIcon(FilePath::instance()->icon("status", "dialog-warning"));
^~~~~~~~~~~~~
/home/dummys/build/cower/keepassxc-git/src/keepassxc/src/http/OptionDialog.cpp:32:11: error: ‘class Ui::OptionDialog’ has no member named ‘warningWidget’; did you mean ‘tabWidget’?
m_ui->warningWidget->setCloseButtonVisible(false);
^~~~~~~~~~~~~
make[2]: *** [src/http/CMakeFiles/keepasshttp.dir/build.make:171: src/http/CMakeFiles/keepasshttp.dir/OptionDialog.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:412: src/http/CMakeFiles/keepasshttp.dir/all] Error 2
make: *** [Makefile:139: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...

Gio commented on 2017-03-18 03:01

On my install the fonts are quite small. The KeepassX2 did not have this problem.

Have no idea where I can change this as there's no option on KeepassXC itself.

widowild commented on 2017-03-16 21:17

@sollpsists:
edit pkgbuild and change
-DWITH_XC_YUBIKEY=ON
by
-DWITH_XC_YUBIKEY=OFF

"-DWITH_XC_YUBIKEY=[ON|OFF] Enable/Disable YubiKey HMAC-SHA1 authentication support (default: OFF)"

solipsists commented on 2017-03-14 10:18

YubiKey Changes breaks the build?

CMake Error at /usr/share/cmake-3.7/Modules/FindPackageHandleStandardArgs.cmake:138 (message):
Could NOT find YubiKey (missing: YUBIKEY_LIBRARIES YUBIKEY_INCLUDE_DIRS)
Call Stack (most recent call first):
/usr/share/cmake-3.7/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE)
cmake/FindYubiKey.cmake:25 (find_package_handle_standard_args)
CMakeLists.txt:212 (find_package)


-- Configuring incomplete, errors occurred!