Package Details: kdevelop-git 0.0.0-7

Git Clone URL: https://aur.archlinux.org/kdevelop-git.git (read-only)
Package Base: kdevelop-git
Description: A C/C++ development environment for KDE. (Git version)
Upstream URL: http://www.kdevelop.org
Licenses: GPL
Conflicts: kdevelop, kdevplatform
Provides: kdevelop, kdevplatform, kdevplatform-git
Replaces: kdevplatform-git
Submitter: mosra
Maintainer: Aetf
Last Packager: Aetf
Votes: 84
Popularity: 0.000019
First Submitted: 2010-05-05 21:15
Last Updated: 2018-01-22 21:14

Dependencies (40)

Required by (7)

Sources (1)

Latest Comments

« First ‹ Previous ... 6 7 8 9 10 11 12 Next › Last »

Rogof commented on 2011-05-10 19:32

Solved... sort of.

I've made a patch that solves this (at least for me), no warranties though. The patch is here: http://pastebin.com/xa2pSPn8

Rogof commented on 2011-05-10 19:21

@mosra: Don't know if has something to do but I'm using the packages in multilib-devel. GCC and KDE versions are the same as yours.

When compiling I got this (omitting warnings):
...
[ 28%] Building CXX object language/CMakeFiles/kdevplatformlanguage.dir/duchain/ducontext.o
In file included from /home/packages/pkgbuild/kdevplatform-git/src/kdevplatform/language/duchain/duchain.cpp:60:0:
/home/packages/pkgbuild/kdevplatform-git/src/kdevplatform/language/duchain/duchainregister.h: In constructor ‘KDevelop::DUChainItemRegistrator<T, Data>::DUChainItemRegistrator()’:
/home/packages/pkgbuild/kdevplatform-git/src/kdevplatform/language/duchain/duchainregister.h:163:50: error: expected primary-expression before ‘,’ token
/home/packages/pkgbuild/kdevplatform-git/src/kdevplatform/language/duchain/duchainregister.h:163:56: error: expected primary-expression before ‘>’ token
/home/packages/pkgbuild/kdevplatform-git/src/kdevplatform/language/duchain/duchainregister.h:163:58: error: expected primary-expression before ‘)’ token
/home/packages/pkgbuild/kdevplatform-git/src/kdevplatform/language/duchain/duchainregister.h: In destructor ‘KDevelop::DUChainItemRegistrator<T, Data>::~DUChainItemRegistrator()’:
/home/packages/pkgbuild/kdevplatform-git/src/kdevplatform/language/duchain/duchainregister.h:166:52: error: expected primary-expression before ‘,’ token
/home/packages/pkgbuild/kdevplatform-git/src/kdevplatform/language/duchain/duchainregister.h:166:58: error: expected primary-expression before ‘>’ token
/home/packages/pkgbuild/kdevplatform-git/src/kdevplatform/language/duchain/duchainregister.h:166:60: error: expected primary-expression before ‘)’ token
make[2]: *** [language/CMakeFiles/kdevplatformlanguage.dir/duchain/ducontext.o] Error 1
make[2]: *** Waiting for unfinished jobs....
In file included from /home/packages/pkgbuild/kdevplatform-git/src/kdevplatform/language/duchain/duchain.cpp:60:0:
/home/packages/pkgbuild/kdevplatform-git/src/kdevplatform/language/duchain/duchainregister.h: In constructor ‘KDevelop::DUChainItemRegistrator<T, Data>::DUChainItemRegistrator()’:
/home/packages/pkgbuild/kdevplatform-git/src/kdevplatform/language/duchain/duchainregister.h:163:50: error: expected primary-expression before ‘,’ token
/home/packages/pkgbuild/kdevplatform-git/src/kdevplatform/language/duchain/duchainregister.h:163:56: error: expected primary-expression before ‘>’ token
/home/packages/pkgbuild/kdevplatform-git/src/kdevplatform/language/duchain/duchainregister.h:163:58: error: expected primary-expression before ‘)’ token
/home/packages/pkgbuild/kdevplatform-git/src/kdevplatform/language/duchain/duchainregister.h: In destructor ‘KDevelop::DUChainItemRegistrator<T, Data>::~DUChainItemRegistrator()’:
/home/packages/pkgbuild/kdevplatform-git/src/kdevplatform/language/duchain/duchainregister.h:166:52: error: expected primary-expression before ‘,’ token
/home/packages/pkgbuild/kdevplatform-git/src/kdevplatform/language/duchain/duchainregister.h:166:58: error: expected primary-expression before ‘>’ token
/home/packages/pkgbuild/kdevplatform-git/src/kdevplatform/language/duchain/duchainregister.h:166:60: error: expected primary-expression before ‘)’ token
...

Anonymous comment on 2011-05-10 19:11

fails me too - gcc version 4.6.0 20110429, KDE 4.6.3. Here is an error - http://pastebin.com/188D9xMn

mosra commented on 2011-05-10 06:49

Rogof: Works for me here (GCC 4.6.0-4, KDE 4.6.3-1). I think it was temporary upstream problem, can you try it again and if it fails, post the error message?

Rogof commented on 2011-05-09 22:10

Compilation fails me with gcc 4.6.0, does anyone else have this problem??

mosra commented on 2011-05-04 20:02

opi: Git is listed as build dependecy (as it is needed only for syncing the Git repository), but KDevelop itself has integrated Subversion support, so the subversion dependency is needed too.

Anonymous comment on 2011-05-03 07:04

Shouldn't the package depend on git instead of subversion?

mosra commented on 2011-02-05 11:11

Changed Git URL to git://anongit.kde.org to prevent overloading git://git.kde.org servers. Update is strongly recommended.

The PKGBUILD automatically updates the url of already cloned repository, so it's not needed to do it manually or clone again.

mosra commented on 2011-02-05 11:08

Changed Git URL to git://anongit.kde.org to prevent overloading git://git.kde.org servers. Update is strongly recommended.

The PKGBUILD automatically updates the url of already cloned repository, so it's not needed to do it manually or clone again.

mosra commented on 2010-12-09 12:16

* Fixed dependencies as bash suggested.