Package Details: kbdd-git 0.7.1.r11.g7f3d9d2-1

Git Clone URL: https://aur.archlinux.org/kbdd-git.git (read-only, click to copy)
Package Base: kbdd-git
Description: Simple daemon and library to make per window layout
Upstream URL: https://github.com/qnikst/kbdd
Keywords: keyboard language layout
Licenses: GPL3
Conflicts: kbdd
Provides: kbdd
Submitter: vchimishuk
Maintainer: vchimishuk
Last Packager: vchimishuk
Votes: 38
Popularity: 0.75
First Submitted: 2015-08-20 20:04
Last Updated: 2020-02-10 23:03

Latest Comments

« First ‹ Previous 1 2 3 4

petRUShka commented on 2012-05-04 20:20

Latest version is 0.6.2. by the way

petRUShka commented on 2012-05-04 20:00

The package version should be updated to 0.6.1 as noticed in issue on github: https://github.com/qnikst/kbdd/issues/16#issuecomment-5518900

petRUShka commented on 2012-05-02 20:15

I catch an error when I compile kbdd

==> Making package: kbdd 0.6-1 (Thu May 3 00:12:47 MSK 2012)
...
In file included from kbdd.c:36:0:
/usr/include/glib-2.0/glib/gthread.h:28:2: error: #error "Only <glib.h> can be included directly."
make[3]: *** [kbdd.o] Error 1


% uname -a
Linux lparch 3.3.4-1-ARCH #1 SMP PREEMPT Sat Apr 28 00:21:22 CEST 2012 x86_64 Intel(R) Core(TM)2 Duo CPU T7700 @ 2.40GHz GenuineIntel GNU/Linux

vchimishuk commented on 2010-12-11 13:57

Unfortunately, kbdd can't be started during boot time, because it requires loaded X server.
I have next error starting it during boot time:
Couldn't connect to session bus: /usr/bin/dbus-launch terminated abnormally with the following error: Autolaunch error: X11 initialization failed.

I'm staring it with Awesome autoload tools. Also it can be started with .xinitrc script.

linx56 commented on 2010-12-10 20:26

It would be great if you add some rc.d script. I just created this https://gist.github.com/736751

vchimishuk commented on 2010-11-29 20:32

Thanks, gray.
I'll periodically watch for the project's updates and upgrade this package.
But if you'll notice new version before me, -- you're welcome press "Flag Out-of-date" button ;)

gray commented on 2010-11-29 20:23

Thanks!
I tried 0.4 and it worked with awesome, so I ask you to upgrade :)

vchimishuk commented on 2010-11-23 20:07

Thanks for your post.
When I've created this package 0.4 version was already released. But it didn't work correct with
Awesome WM. I've spoke with author of kbdd and he promised fix it in next releases, and recommended me
using 0.3.2 version. Now I see 0.4.1 version was released. I'll try it next days and update this package
if it will be compatible with Awesome.

gray commented on 2010-11-23 19:56

ver 0.4 is out! Please, update.

pkgname=kbdd
pkgver=0.4
...
source=("https://github.com/downloads/qnikst/$pkgname/$pkgname-$pkgver.tar.bz2")
md5sums=('5abecb62204151666975609444ff5566')