Package Details: kazam 1.4.5-9

Git Clone URL: https://aur.archlinux.org/kazam.git (read-only, click to copy)
Package Base: kazam
Description: Screencast and screenshot application created with design in mind
Upstream URL: https://launchpad.net/kazam
Keywords: screencast
Licenses: GPL
Submitter: Maxwel
Maintainer: heavysink
Last Packager: heavysink
Votes: 129
Popularity: 0.43
First Submitted: 2012-05-21 21:04
Last Updated: 2020-06-12 07:05

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

Strit commented on 2014-10-21 10:37

@FredBezies Okay thanks. Just thought you might have heard something as the maintainer of the Arch version. :P

FredBezies commented on 2014-10-21 09:42

@strit : no need to flag this package as out-of-date. For your sound problem, just ask upstream. I'm only trying to keep it updated. I have no infos from developers.

Thanks.

Strit commented on 2014-10-21 09:29

When is the new version coming, where the mono sound is fixed?
Launchpad said expected on 2014-09-01, which is 1 and a half month ago.

FredBezies commented on 2014-08-23 06:39

Kazam is now up-to-date : version 1.4.5, uploaded on 18 august 2014.

https://launchpad.net/kazam/stable/1.4.5

FredBezies commented on 2014-08-23 06:20

Adopting it. Will update it soon.

petelewis commented on 2014-04-07 16:35

This appears to need pulseaudio running, which is a shame :-( Should probably be added as a dependency.

% kazam
ERROR Kazam - Could not find any typelib for AppIndicator3
Traceback (most recent call last):
File "/usr/lib/python3.4/site-packages/kazam/pulseaudio/pulseaudio.py", line 219, in start
raise PAError(PA_UNABLE_TO_CONNECT, "Unable to connect to PulseAudio server.")
kazam.pulseaudio.error_handling.PAError: (4, 'Unable to connect to PulseAudio server.')

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/usr/bin/kazam", line 147, in <module>
app = KazamApp(datadir, dist, args.debug, args.test, args.nosound, args.silent)
File "/usr/lib/python3.4/site-packages/kazam/app.py", line 121, in __init__
prefs.pa_q.start()
File "/usr/lib/python3.4/site-packages/kazam/pulseaudio/pulseaudio.py", line 221, in start
raise PAError(PA_UNABLE_TO_CONNECT2, "Unable to initiate connection to PulseAudio server.")
kazam.pulseaudio.error_handling.PAError: (5, 'Unable to initiate connection to PulseAudio server.')

FredBezies commented on 2014-03-21 13:03

Some modifications :

1) Kazam is now in version 1.4.4
2) No need to add -0ubuntu1 anymore
3) correct patch lines :

-DISTRO='Ubuntu'
-RELEASE='14.04'
+DISTRO='Archlinux'
+RELEASE='rolling'

drvanon commented on 2013-12-13 16:30

Sorry, I flagged out of date because I had a bug, that should have been fixed in an earlier release. Excuse me.

kristianjgs commented on 2013-08-23 20:13

Install but when I select Capture Button dont start and in the icon indicator show show cancel countdown

grugnog commented on 2013-04-04 05:24

Here are the changes I needed to make to use the 1.4.2 release. Note that it now uses python 3, not 2 so a lot of the dependencies have changed. A couple of todos:

- I don't know which specific gst-* packages are required (we need to dig in and work out which ones have the neccessary codecs) - they are all listed for now.
- There are errors about missing AppIndicator3 and Keybinder, but it seems to work for me without these.

--- kazam/PKGBUILD 2012-11-28 12:50:19.000000000 -0800
+++ kazam-1.4.2/PKGBUILD 2013-04-03 22:16:30.368016274 -0700
@@ -1,16 +1,17 @@
pkgname=kazam
-pkgver=1.3.4
+pkgver=1.4.2
pkgrel=1
pkgdesc="A screencasting program with design in mind"
arch=('i686' 'x86_64')
url="https://launchpad.net/kazam"
license=('GPL')
groups=()
-depends=('python2-cairo' 'pygtk' 'ffmpeg' 'gstreamer0.10' 'python2-xdg' 'python-xlib' 'libmatroska' 'gnome-python-desktop' 'python2-pycurl' 'python2-gdata' 'libtheora' 'python-keybinder' 'python2-distutils-extra')
+depends=('python-gobject' 'pygtk' 'ffmpeg' 'gstreamer' 'python-xdg' 'python-xlib' 'libmatroska' 'libtheora' 'libwnck3' 'python-dbus' 'gst-plugins-bad' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-ugly' 'gst-libav')
+makedepends=('python-distutils-extra')
conflicts=('kazam-bzr' 'kazam-stable-bzr')

-source=("https://launchpad.net/${pkgname}/unstable/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz")
-md5sums=('67cf54f5de4be407b509d369b3997bd9')
+source=("https://launchpad.net/${pkgname}/stable/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz")
+md5sums=('35718a907637bb7ed0247f11f0026ec7')

build() {
:
@@ -18,6 +19,6 @@

package() {
cd "${srcdir}/${pkgname}-${pkgver}-0ubuntu1"
- python2 setup.py install --root ${pkgdir}
+ python setup.py install --root ${pkgdir}
}