Package Details: kazam 1.4.5-7

Git Clone URL: https://aur.archlinux.org/kazam.git (read-only)
Package Base: kazam
Description: A screencasting program with design in mind
Upstream URL: https://launchpad.net/kazam
Keywords: screencast
Licenses: GPL
Conflicts: kazam-bzr, kazam-stable-bzr
Submitter: Maxwel
Maintainer: fbrennan
Last Packager: fbrennan
Votes: 120
Popularity: 0.176630
First Submitted: 2012-05-21 21:04
Last Updated: 2018-12-26 14:40

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

argenis commented on 2018-08-23 12:39

I tried @wslorodecki suggestion, but a get this:

WARNING Kazam - Running from local directory, AppIndicator icons could be missing. Traceback (most recent call last): File "./bin/kazam", line 97, in <module> from kazam.version import * ModuleNotFoundError: No module named 'kazam'</module>

wskorodecki commented on 2018-08-23 07:59

I'm not a Python developer so I'm not sure if changes that I've applied are 100% valid, but after that Kazam is working fine on my environment: https://github.com/wskorodecki/kazam/commit/504e68f4f2451e30b4614f63793f26c1b33b3f40

The fastest way to get Kazam running again is to clone the "archlinux" branch and start Kazam from local directory: ./bin/kazam

andheisus commented on 2018-08-19 04:38

After an update set I can no longer open kazam, and am getting errors I am not sure how to interpret:

$ kazam /usr/bin/kazam:32: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded. from gi.repository import Gtk /usr/bin/kazam:75: DeprecationWarning: dist() and linux_distribution() functions are deprecated in Python 3.5 dist = platform.linux_distribution() Traceback (most recent call last): File "/usr/bin/kazam", line 146, in <module> from kazam.app import KazamApp File "/usr/lib/python3.7/site-packages/kazam/app.py", line 35, in <module> from kazam.backend.prefs import * File "/usr/lib/python3.7/site-packages/kazam/backend/prefs.py", line 478, in <module> prefs = Prefs() File "/usr/lib/python3.7/site-packages/kazam/backend/prefs.py", line 119, in init self.config = KazamConfig() File "/usr/lib/python3.7/site-packages/kazam/backend/config.py", line 76, in init ConfigParser.init(self, self.DEFAULTS[0]['keys']) File "/usr/lib/python3.7/configparser.py", line 638, in init self._read_defaults(defaults) File "/usr/lib/python3.7/configparser.py", line 1216, in _read_defaults self.read_dict({self.default_section: defaults}) File "/usr/lib/python3.7/configparser.py", line 753, in read_dict self.set(section, key, value) File "/usr/lib/python3.7/site-packages/kazam/backend/config.py", line 127, in set self.add_section(section) File "/usr/lib/python3.7/configparser.py", line 1205, in add_section super().add_section(section) File "/usr/lib/python3.7/configparser.py", line 655, in add_section raise ValueError('Invalid section name: %r' % section) ValueError: Invalid section name: 'DEFAULT'</module></module></module>

Is there a way to fix this? It won't open in the xfce whisker menu or the terminal. Thanks.

silenx commented on 2018-04-25 12:40

I'm also interested in kazam, version 1.5.3 ( unstable ) have more some little feature ( example mouse click highlight )

51v4n commented on 2018-04-19 22:42

@Bachsau thinking about it, but for now taking care if something it's required (but no one is blaming about nothing), probably a deletion will happen in a future.

Anonymous comment on 2018-04-17 22:10

If something is working and there is no obvious reason to do any changes to it, I would not consider it dead just because there is no constant development.

FredBezies commented on 2017-01-25 20:28

Disowning Kazam. Seems to be kinda dead upstream :(

dewyatt commented on 2016-10-26 22:11

For anyone else looking for screencast software with webcam overlay support, take a look at the community/obs-studio package.

quenyen commented on 2016-10-10 16:54

I am still working on this FredBezies.....right now I am getting only this output...
INFO Indicator - Unable to import Keybinder, hotkeys not available.
../kazam/app.py:169: Warning: value "((GtkIconSize) 32)" of type 'GtkIconSize' is invalid or out of range for property 'icon-size' of type 'GtkIconSize'
self.builder.add_from_file(os.path.join(prefs.datadir, "ui", "kazam.ui"))

(kazam:5303): Gtk-WARNING **: Can't set a parent on widget which has a parent

(kazam:5303): Gtk-WARNING **: Can't set a parent on widget which has a parent
Traceback (most recent call last):
File "../kazam/app.py", line 677, in cb_record_clicked
self.run_counter()
File "../kazam/app.py", line 1010, in run_counter
self.countdown = CountdownWindow(self.indicator, show_window=prefs.countdown_splash)
File "../kazam/frontend/window_countdown.py", line 92, in __init__
rect = cairo.RectangleInt(0, 0, 1, 1)
AttributeError: module 'cairo' has no attribute 'RectangleInt'

This seems to indicate cairo hasn't got the RectangleInt attribute anymore. I do not think that is the case, I ran a test program where I used RectangleInt and it seems to work on my manjaro linux system (using python3)


I will keep working on it...I really want this thing to work.

quenyen commented on 2016-10-08 21:46

Okay...I think I have something that will work. I have fixed the main issues to at least get it running. I can at least run it locally on my Manjaro box. I would make a new one called "kazam-git" but I haven't done any packages yet and don't think this should be my first one. Here is the git repository where I have it working at least on my box.

https://github.com/chrisfair/kazam.git


So give that a go and see if we can get a working 1.5.4 version. I guess I will begin developing this since it looks like the original has lost support. At the very least I can fork it and begin debugging.