Package Details: kathara 3.3.0-1

Git Clone URL: https://aur.archlinux.org/kathara.git (read-only, click to copy)
Package Base: kathara
Description: Lightweight network emulation system based on Docker containers.
Upstream URL: https://www.kathara.org/
Keywords: docker kubernetes network-emulation nfv
Licenses: GPL3
Submitter: skazza94
Maintainer: skazza94 (5amu)
Last Packager: skazza94
Votes: 1
Popularity: 0.001806
First Submitted: 2021-02-18 10:45
Last Updated: 2021-12-20 11:46

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

famar commented on 2021-12-26 11:19

I confirm the issue of @wh75er on finding a too specific version of pip.

wh75er commented on 2021-12-25 17:26

I'm not sure if it's relevant to package outdating, but build fails on prepare phase because of incorrect python version

==> Starting prepare()...
.cache/yay/kathara/PKGBUILD: line 20: .cache/yay/kathara/src/venv/bin/pip3.9: No such file or directory

I have python3.10 and pip3.10 in my system, maybe just only use major version:

$srcdir/venv/bin/pip3

instead of hardcoded minor version:

$srcdir/venv/bin/pip3.9

?

UPD.

It didn't help. Looks like pyuv package is broken and not compatible with python3.10

I'm getting error on setup.py install pyuv

https://github.com/saghul/pyuv/issues/271

project is unmaintaned right now