Package Details: kalu 4.3.0-1

Git Clone URL: https://aur.archlinux.org/kalu.git (read-only)
Package Base: kalu
Description: Upgrade notifier w/ AUR support, watched (AUR) packages, news
Upstream URL: https://jjacky.com/kalu
Licenses: GPL3+
Submitter: jjacky
Maintainer: jjacky
Last Packager: jjacky
Votes: 181
Popularity: 0.229529
First Submitted: 2012-02-14 18:03
Last Updated: 2018-06-04 17:45

Latest Comments

« First ‹ Previous ... 6 7 8 9 10 11 12 13 14 Next › Last »

adam777 commented on 2012-12-05 21:45

Oh, I suppose the "update system" button should have triggered an alarm.
Guess I judged too soon. Thanks.

jjacky commented on 2012-12-05 17:05

Yes, this is normal. Computing the list of packages with upgrades for notifications is a no-user-interaction process, so in cases of conflict such as this one (where user input is required to know what to do), you get such a message on the notification.

However, you can still use kalu's updater to do the sysupgrade, in which case you'll then be asked the same question(s) you would with pacman, only in a GUI ;)

adam777 commented on 2012-12-05 16:59

Latest dbus update caused the following message to appear:

Unable to compile list of packages
Failed to prepare transaction:
conflicting dependencies
- dbus and dbus-core are in conflict

Manually using pacman -Syu yields the following:
:: Replace dbus-core with core/dbus? [Y/n]

I accepted and update continued as expected.

jjacky commented on 2012-11-09 09:17

I don't think there's anything I can do, no. You could try another using theme, if it still happens then it might be an issue with gtk3 & KDE, else it'd be coming from oxygen-gtk.

I don't use KDE nor that theme, but I haven't had any issue with the latest gtk3.

adam777 commented on 2012-11-09 08:48

Hello,
Not sure it's even up to you, but latest gtk3 messes up kalu under KDE using the oxygen-gtk theme.
Scrrenshot:
http://i.imgur.com/nwKQP.png

jjacky commented on 2012-10-27 18:41

Yes, thanks, I saw that too. It was due to a bug parsing JSON from the AUR, which always assumed valid JSON. Version 1.3.0 is out now, fixing this (amongst other things).

adam777 commented on 2012-10-27 17:14

Hi,
There seem to be some bug with AUR checking.
During the recent AUR downtime, whenever Kalu checked for updates, it crashed (tray icon disappeared, process not running).
As nothing changed comparing to current situation except the AUR being back up (now update checking works as usual), and the crashed was 100% reproducible, I think the blame lies there.
Sadly I do not know the exect response Kalu received during that period, so I'm not sure how you can address it.

jjacky commented on 2012-10-21 19:24

Yes, little bug due to the switch of the main site to https-only (kalu used http and didn't follow redirections).

Fixed in v1.2.1, now available.

adam777 commented on 2012-10-21 18:23

I'm having problems with news checking.

Unable to check the news
Error on line 9 char 8: Element 'body' was closed, but the currently open element is 'hr'.

News hasn't changed on front page, perhaps something changed in the page code.

gabx commented on 2012-10-06 17:26

I use polkit 0.107-2, which support systemd.
I didn't have a running agent ! Installing polkit-gnome solved my issue. I have now the UI window.
TY.