Package Details: k2pdfopt 2.51-1

Git Clone URL: https://aur.archlinux.org/k2pdfopt.git (read-only, click to copy)
Package Base: k2pdfopt
Description: A tool that optimizes PDF files for viewing on mobile readers
Upstream URL: http://www.willus.com/k2pdfopt/
Keywords: convert ebook k2pdfopt kindle pdf reflow
Licenses: GPL3
Submitter: FacuTuesca
Maintainer: None
Last Packager: jose1711
Votes: 44
Popularity: 0.61
First Submitted: 2014-03-14 21:46
Last Updated: 2019-03-24 21:00

Latest Comments

1 2 3 4 Next › Last »

jose1711 commented on 2020-06-18 21:39

Applying patches from Debian sid I still get error from linker:

/usr/bin/ld: willuslib/libwilluslib.a(ocrtess.c.o): in function `ocrtess_set_logfile':
ocrtess.c:(.text+0x1a4): undefined reference to `tess_capi_set_logfile'
/usr/bin/ld: willuslib/libwilluslib.a(ocrtess.c.o): in function `ocrtess_debug_message':
ocrtess.c:(.text+0x1b4): undefined reference to `tess_capi_debug_message'
/usr/bin/ld: willuslib/libwilluslib.a(ocrtess.c.o): in function `ocrtess_init':
ocrtess.c:(.text+0x1192): undefined reference to `tess_capi_init'
/usr/bin/ld: willuslib/libwilluslib.a(ocrtess.c.o): in function `ocrtess_end':
ocrtess.c:(.text+0x11e4): undefined reference to `tess_capi_end'
/usr/bin/ld: willuslib/libwilluslib.a(ocrtess.c.o): in function `ocrtess_ocrwords_from_bmp8':
ocrtess.c:(.text+0x1575): undefined reference to `tess_capi_get_ocr_multiword'
/usr/bin/ld: willuslib/libwilluslib.a(ocrtess.c.o): in function `ocrtess_from_bmp8':
ocrtess.c:(.text+0x1a84): undefined reference to `tess_capi_get_ocr'
collect2: error: ld returned 1 exit status

probably some kind of conflict with modified tesseract. I don't really have time to fix this so if someone wants to step in.. I am disowning this now. Thanks.

cvelteren commented on 2020-05-26 09:49

How to build this package with ocr?

Un1Gfn commented on 2019-02-23 08:31

I don't know much about statically/dynamically linking so I give up (for now). Sorry for adopting the package and doing nothing.

The k2pdfopt->libwillus->tesseract(modded)->leptonica(modded) dependency has been such a beast.

Possibly useful reference: repology and nixpkgs

FacuTuesca commented on 2019-01-28 18:10

I can no longer maintain this package. Up for adoption.

m040601 commented on 2019-01-28 13:45

v2.50 was released in Dec 2018 and v2.51 in Jan 2019 with important enhancements compiling with the Tesseract v4.0.0 library

FacuTuesca commented on 2017-05-09 00:57

@ahxxm @guiniol @frankspace:
Updated to v2.41

ahxxm commented on 2017-04-16 05:03

v2.41 was released in Feb, still under maintenance?

FacuTuesca commented on 2017-01-08 00:26

Sorry for the delay. I'm having trouble compiling the new versions of k2pdfopt with gocr 0.50. I'll upload the new version as soon as I find a solution.

guiniol commented on 2017-01-04 16:31

@FacuTuesca: as frankspace said, the version is now up to 2.36 and it includes support for linux. Could you update it?

frankspace commented on 2016-12-13 07:42

It's actually up to verion 2.36 now, but I can't flag it out of date because it's already flagged out of date.