Package Details: julia-mbedtls 0.6.8-1

Git Clone URL: https://aur.archlinux.org/julia-mbedtls.git (read-only)
Package Base: julia-mbedtls
Description: Wrapper around mbedtls for Julia
Upstream URL: https://github.com/JuliaWeb/MbedTLS.jl
Licenses: MIT
Submitter: jonathon
Maintainer: jonathon
Last Packager: jonathon
Votes: 0
Popularity: 0.000000
First Submitted: 2018-09-02 16:03
Last Updated: 2019-03-06 19:49

Latest Comments

robbystk commented on 2019-07-15 18:35

Check fails with the following error:

==> Starting check()...
ERROR: LoadError: error compiling Type: could not load library "/usr/lib/libmbedtls.so"
/usr/lib/libmbedtls.so: undefined symbol: mbedtls_x509_crt_verify_restartable
Stacktrace:
 [1] top-level scope at ~/builds/julia-mbedtls/src/MbedTLS.jl-0.6.8/test/runtests.jl:104
in expression starting at ~/builds/julia-mbedtls/src/MbedTLS.jl-0.6.8/test/runtests.jl:89
==> ERROR: A failure occurred in check().
    Aborting...

I tried restarting after installing mbedtls, and verified that libmbedtls.so exists. It doesn't appear that the dependency check script embedded in the PKGBUILD gets executed but I'm not sure.