Package Details: jrnl-git 0.r775.350f0a1-1

Git Clone URL: https://aur.archlinux.org/jrnl-git.git (read-only, click to copy)
Package Base: jrnl-git
Description: A simple command line journal application that stores your journal in a plain text file
Upstream URL: https://jrnl.sh/
Licenses: MIT
Conflicts: jrnl
Submitter: ckafi
Maintainer: Baitinq
Last Packager: Baitinq
Votes: 3
Popularity: 0.000000
First Submitted: 2015-08-13 19:38
Last Updated: 2019-10-06 10:46

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

pbateman commented on 2020-08-18 11:14

Currently doesn't build on standard up-to-date install (python 3.8.5):

poetry install The "black" dependency specifies the "allows-prereleases" property, which is deprecated. Use "allow-prereleases" instead. The currently activated Python version 3.8.5 is not supported by the project (>=3.6.0, <3.8.0). Trying to find and use a compatible version.

[NoCompatiblePythonVersionFound] Poetry was unable to find a compatible version. If you have one, you can explicitly use it via the "env use" command. make: *** [Makefile:29: install] Error 1 ==> ERROR: A failure occurred in package(). Aborting... :: failed to build jrnl-git package(s)

agwblack commented on 2020-08-10 13:37

I get the following error:

The "black" dependency specifies the "allows-prereleases" property, which is    deprecated. Use "allow-prereleases" instead.
The currently activated Python version 3.8.5 is not supported by the project  (>=3.6.0, <3.8.0).
Trying to find and use a compatible version.

[NoCompatiblePythonVersionFound]
Poetry was unable to find a compatible version. If you have one, you can explicitly use it via the "env use" command.
make: *** [Makefile:29: install] Error 1
==> ERROR: A failure occurred in package().
    Aborting....

aureooms commented on 2020-01-06 22:28

Why isn't the source https://github.com/jrnl-org/jrnl ?

Jeinzi commented on 2020-01-04 02:50

Could you please sync the dependencies with those in the normal jrnl package? :)

swalladge commented on 2018-08-01 13:47

Missing dependency: requires python-keyrings-alt to run (not optional).