Package Details: jre7 7u80-1

Git Clone URL: https://aur.archlinux.org/jre7.git (read-only)
Package Base: jre7
Description: Oracle Java 7 Runtime Environment (public release - end of support)
Upstream URL: http://www.oracle.com/technetwork/java/javase/downloads/jre7-downloads-1880261.html
Keywords: java-openjfx java-runtime-headless-jre java-runtime-jre java-web-start-jre
Licenses: custom
Provides: java-openjfx=7, java-runtime=7, java-runtime-headless=7, java-runtime-headless-jre=7, java-runtime-jre=7, java-web-start=7, java-web-start-jre=7
Submitter: joschi
Maintainer: severach
Last Packager: Det
Votes: 41
Popularity: 0.001808
First Submitted: 2013-09-11 18:21
Last Updated: 2017-11-15 21:57

Required by (1000)

Sources (3)

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

rafaelff commented on 2014-10-15 15:16

Version 7u72 is out. Please update PKGBUILD

_major=7
_minor=72
_build=b14
md5sums=(`curl -sL https://www.oracle.com/webfolder/s/digest/${_major}u{$_minor}checksum.html | sed -nr "s|.*>${source##*/}</td> *<td>(<*[^<]*).*|\1|p"`)

rafaelff commented on 2014-10-13 15:12

@joschi: please set this package to work with 'java-runtime-common' and 'java-environment-common'

Det commented on 2014-10-13 03:02

You didn't reply to my email sent almost a month ago about cleaning up the Java packages.

Are you still alive?

galaux commented on 2014-10-05 13:15

FYI, current package "java-common" will be split due to https://bugs.archlinux.org/task/41883

The only changes needed will be:
- for java-runtime-headless providing packages to now depend on "java-runtime-common" rather than "java-common"
- for java-environment providing packages to now depend on "java-environment-common"

These new packages are expected to be pushed to extra next week-end.

galaux commented on 2014-10-05 12:17

FYI, chances are current package "java-common" will be split due to https://bugs.archlinux.org/task/41883

joschi commented on 2014-08-31 13:03

@josephgbr: Please see https://aur.archlinux.org/packages/jre7-oracle/

rafaelff commented on 2014-08-25 15:03

@joschi: hey, why don't you try to set the package to use archlinux-java, provided by 'java-common' ? Looks like you would need to drop jre.csh and jre.sh, move /opt/java to /usr/lib/jvm/, some other stuff.

test0 commented on 2014-08-13 01:33

@joschi: OK, I removed (sudo pacman -Rdd jre7) and reinstalled (yaourt -Sa jre7) and it worked fine. I checked pacman.log for the previous updates and there's nothing relevant there so it seems whatever is happening is before pacman (in the makepkg stage). We'll have to wait until the next update so I can save the yaourt output since AFAIK there are no logs for it (or makepkg).

joschi commented on 2014-08-10 20:39

@test0 What's the exact error you get when trying to install or upgrade the package?

test0 commented on 2014-08-10 20:34

@joschi: this package always fails to update (using yaourt -Sua) unless I do it as root (which isn't recommended). I've noticed it for, at least, the past 3 or 4 updates. Is this the intended/necessary behavior, a bug or did I do something wrong ?? If anyone else has any clues/workarounds I'd appreciate the help !!