Package Details: joplin 1.3.18-1

Git Clone URL: https://aur.archlinux.org/joplin.git (read-only, click to copy)
Package Base: joplin
Description: A note taking and to-do application with synchronization capabilities
Upstream URL: https://joplinapp.org/
Keywords: markdown note notetaking productivity
Licenses: MIT
Submitter: masterkorp
Maintainer: masterkorp
Last Packager: masterkorp
Votes: 149
Popularity: 9.32
First Submitted: 2018-04-18 16:33
Last Updated: 2020-11-06 15:59

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

SweetestRug commented on 2020-08-03 16:14

Hi, as of 1.0.233, joplin builds fine. The GUI works well. However, on launching the cli version, it throws this error:

internal/modules/cjs/loader.js:1033
  throw err;
  ^

Error: Cannot find module 'immer'
Require stack:
- /usr/share/joplin-cli/lib/services/ResourceEditWatcher/reducer.js
- /usr/share/joplin-cli/lib/reducer.js
- /usr/share/joplin-cli/lib/BaseApplication.js
- /usr/share/joplin-cli/app.js
- /usr/share/joplin-cli/main.js
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:1030:15)
    at Function.Module._load (internal/modules/cjs/loader.js:899:27)
    at Module.require (internal/modules/cjs/loader.js:1090:19)
    at require (internal/modules/cjs/helpers.js:75:18)
    at Object.<anonymous> (/usr/share/joplin-cli/lib/services/ResourceEditWatcher/reducer.js:3:17)
    at Module._compile (internal/modules/cjs/loader.js:1201:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1221:10)
    at Module.load (internal/modules/cjs/loader.js:1050:32)
    at Function.Module._load (internal/modules/cjs/loader.js:938:14)
    at Module.require (internal/modules/cjs/loader.js:1090:19) {
  code: 'MODULE_NOT_FOUND',
  requireStack: [
    '/usr/share/joplin-cli/lib/services/ResourceEditWatcher/reducer.js',
    '/usr/share/joplin-cli/lib/reducer.js',
    '/usr/share/joplin-cli/lib/BaseApplication.js',
    '/usr/share/joplin-cli/app.js',
    '/usr/share/joplin-cli/main.js'
  ]
}

masterkorp commented on 2020-07-08 08:40

I would like to remmind that this package does not update to pre-releases

Deuchnord commented on 2020-06-25 12:49

Can you copy the application icon to /usr/share/pixmaps/joplin.png and update the line 6 of the joplin.desktop to:

Icon=joplin

This will make it possible to customize it in icon themes.

SweetestRug commented on 2020-06-15 21:38

Build as of June 15 is failing. Failure starts at

/bin/sh: pkg-config: command not found gyp: Call to 'pkg-config --cflags libsecret-1' returned exit status 127 while in binding.gyp. while trying to load binding.gyp

with multiple gyp ERR! following. For what its worth, I am running Manjaro.

bedwardly-down commented on 2020-05-22 23:21

It’s not Zemoose’s fault. To keep certain packages from breaking and bugs from arising, Joplin’s main team is locking in specific versions. The dependencies have gotten managed better than they used to be but the whole “use new libraries where able to save time and code maintenance” approach is a bit problematic at times.

I wouldn’t recommend updating most packages if you can avoid it because of this.

thelazyoxymoron commented on 2020-05-22 20:45

@ZeMoose, just to be on the safe side, you should periodically check for npm update and resolve those security vulnerabilities by running npm audit fix.

malcolm commented on 2020-05-21 13:56

this version is very outdated. please do something

RockhopperP commented on 2020-05-15 08:17

If confronted with a 'fatal error: unknown table: settings' it helped me to rm -rf ~/.config/Joplin/ ~/.config/joplin-desktop/ and reinstall joplin from the already compiled package.

Such was suggested here: https://discourse.joplinapp.org/t/solved-linux-fatal-error-unknown-table-settings/6253

ZeMoose commented on 2020-05-08 03:58

Should I be concerned about the hundreds of low and moderate severity vulnerabilities reported by npm during the build process?

avndp commented on 2020-05-06 02:47

Building fails all the time.