Package Details: joplin-appimage 1.0.233-1

Git Clone URL: https://aur.archlinux.org/joplin-appimage.git (read-only, click to copy)
Package Base: joplin-appimage
Description: The latest pre-released AppImage of Joplin - a cross-platform note taking and to-do app
Upstream URL: https://github.com/laurent22/joplin
Keywords: appimage joplin
Licenses: MIT
Submitter: kirillz
Maintainer: silenf
Last Packager: silenf
Votes: 12
Popularity: 1.70
First Submitted: 2020-06-19 14:03
Last Updated: 2020-08-05 07:39

Pinned Comments

hvksmr1996 commented on 2020-02-22 04:18

Attention

This package is to download AppImage file from GitHub Release and install it. It is not out-of-date if the latest release lacks such file.

Also this is what a true latest release looks like: https://i.imgur.com/iQp0pcX.png

Latest Comments

1 2 Next › Last »

NeedleNardleNoo commented on 2020-07-30 09:29

The error in package() appears to come from the most recent change to the PKGBUILD. The line-change that needs to be reverted is the following:

        pkgrel = 1
-       url = https://github.com/laurent22/joplin
+       url = https://github.com/laurent22/joplin/releases/tag/v1.0.229
        arch = x86_64

The url with .../releases/tag/v1.0.229 returns an html page instead of the intended source files. This fix also works when I modify the version to v1.0.232.

Parsec82 commented on 2020-07-30 07:50

Same problem on my system

amatriain commented on 2020-07-26 12:07

Build version 1.0.229-1 fails:

$ makepkg -s
==> Making package: joplin-appimage 1.0.229-1 (Sun 26 Jul 2020 14:05:39 CEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found Joplin-1.0.229.AppImage
  -> Found LICENSE
==> Validating source files with sha512sums...
    Joplin-1.0.229.AppImage ... Skipped
    LICENSE ... Skipped
==> Extracting sources...
==> Removing existing $pkgdir/ directory...
==> Entering fakeroot environment...
==> Starting package()...

     _             _ _       
    | | ___  _ __ | (_)_ __  
 _  | |/ _ \| '_ \| | | '_ \ 
| |_| | (_) | |_) | | | | | |
 \___/ \___/| .__/|_|_|_| |_|
            |_|              

==> ERROR: A failure occurred in package().
    Aborting...

kirillz commented on 2020-07-24 09:37

I agree, thank you. Somehow not exactly. I'll fix it in the next commit. "The latest pre-released AppImage of Joplin - a cross-platform note taking and to-do app"

marties commented on 2020-07-22 15:48

Hi, thanks for your answer, i checked the URL and it's labeled pre-release, maybe you should alter your description accordingly and not 'The latest released'. Anyway thanks for your involvement.

kirillz commented on 2020-07-22 11:29

Thank you for watching. Here is the answer to your question. https://github.com/laurent22/joplin/releases/tag/v1.0.229 I checked the functionality of the application myself. You can also take the stable version if you are not happy with the current one.

marties commented on 2020-07-21 13:47

Hello, how is this possible that your Joplin version is 1.0.229-1 while the github https://github.com/laurent22/joplin list the last update as 1.0.227 14 days ago?

I think this a dangerous use, as downgrading to the real version keeps the user out of his previous notes (wrong sqlite database version).

SweetestRug commented on 2020-06-21 15:28

Thanks kirillz for maintaining this package! Good news: The update to joplin-appimage-1.0.224-1 fixed the problem. All is working well on 1.0.224-1.

kirillz commented on 2020-06-20 17:56

SweetestRug, Thx for comment. Unfortunately, 223 doesn’t work for me either, but 221 worked. Downgraded to working version 221

SweetestRug commented on 2020-06-20 17:50

Joplin 1.0.223 fails to load application, either from the installed appimage or the downloaded appimage itself.