Package Details: jitsi-meet-prosody-bin 1.0.4466-1

Git Clone URL: https://aur.archlinux.org/jitsi-meet-prosody-bin.git (read-only, click to copy)
Package Base: jitsi-meet-prosody-bin
Description: Jitsi Meet Prosody Plugins binary
Upstream URL: https://jitsi.org/jitsi-meet/
Licenses: Apache
Conflicts: jitsi-meet-prosody
Provides: jitsi-meet-prosody
Submitter: celogeek
Maintainer: celogeek (C0rn3j)
Last Packager: celogeek
Votes: 1
Popularity: 0.009597
First Submitted: 2020-07-17 10:58
Last Updated: 2020-10-16 16:28

Latest Comments

celogeek commented on 2020-05-27 00:11

Hi,

you can directly use the content in github instead of picking the debian package.

Here for example:

https://github.com/celogeek/jitsi-meet-standalone-arch/blob/master/PKGBUILD#L106

You need to fetch the latest stable package here: https://github.com/jitsi/jitsi-meet/archive/${_stable_tag}.tar.gz

And stable tag can we found here: https://api.github.com/repos/jitsi/jitsi-meet/tags

celogeek commented on 2020-05-20 10:11

Hi, this package is outdated.

I have apply change to it, in order to fetch the latest release automatically and update the pkgver accordingly. Here my PKGBUILD:


_pkgname=jitsi-meet
pkgname=${_pkgname}-prosody-plugins
pkgver=1.0.4074
pkgrel=1
_debrel=1
pkgdesc="Prosody plugins for jitsi-meet"
arch=('any')
url="https://jitsi.org/jitsi-meet/"
license=('Apache')
depends=('prosody')
options=('!strip')

source=()
sha256sums=()

pkgver() {
  curl --silent "https://api.github.com/repos/jitsi/$_pkgname/releases/latest" | jq -r .name
}

build() {
  curl -L "https://download.jitsi.org/stable/${_pkgname}-prosody_${pkgver}-${_debrel}_all.deb" -o prosody.deb
}

package() {
  ar p "${srcdir}/prosody.deb" data.tar.xz | tar xJv -C "${pkgdir}"

  rm -r "${pkgdir}/usr/share/doc/jitsi-meet-prosody"
  mv "${pkgdir}/usr/share/jitsi-meet/prosody-plugins" "${pkgdir}/usr/share/jitsi-meet-prosody-plugins"
  rmdir "${pkgdir}/usr/share/jitsi-meet"
  mv "${pkgdir}/usr/share/jitsi-meet-prosody" "${pkgdir}/usr/share/doc/jitsi-meet-prosody-plugins"
  sed -i 's@/usr/share/jitsi-meet/prosody-plugins@/usr/share/jitsi-meet-prosody-plugins@' "${pkgdir}/usr/share/doc/jitsi-meet-prosody-plugins/prosody.cfg.lua-jvb.example"
}

# vim: set ts=2 sw=2 et:

hope that can help.

fordprefect commented on 2020-05-08 11:27

since you are building from the debian packages, please reupload this package as -bin to conform with the naming convention.