Package Details: jellyfin-server-git 10.6.0.r3918.g360d80c873-1

Git Clone URL: https://aur.archlinux.org/jellyfin-git.git (read-only, click to copy)
Package Base: jellyfin-git
Description: Jellyfin server component
Upstream URL: https://github.com/jellyfin/jellyfin
Licenses: GPL2
Conflicts: jellyfin-server
Provides: jellyfin-server
Submitter: z3ntu
Maintainer: z3ntu
Last Packager: z3ntu
Votes: 17
Popularity: 0.013005
First Submitted: 2018-12-11 16:45
Last Updated: 2021-04-30 19:53

Pinned Comments

z3ntu commented on 2019-01-08 17:20

For all people flagging the package out of date: This is a -git package that pulls down the latest sources from the git repository, so unless the build process is broken, don't flag this package out of date! Just rebuild it.

Latest Comments

1 2 3 Next › Last »

MrTimscampi commented on 2021-04-24 13:58

Do note that we switched from Yarn to NPM recently, so this package currently fails to build.

z3ntu commented on 2021-04-12 16:06

The package currently doesn't build due to Microsoft messing up with their SSL certificates. Read the last couple of comments in https://aur.archlinux.org/pkgbase/jellyfin for more info.

edit: fixed now!

Recompiler commented on 2021-02-01 03:04

How do I reconcile this circular dependency?

:: netstandard-targeting-pack-bin and netstandard-targeting-pack are in conflict (netstandard-targeting-pack-2.1). Remove netstandard-targeting-pack? [y/N] Y

error: failed to prepare transaction (could not satisfy dependencies)

:: removing netstandard-targeting-pack breaks dependency 'netstandard-targeting-pack' required by dotnet-sdk

:: removing netstandard-targeting-pack breaks dependency 'netstandard-targeting-pack' required by dotnet-targeting-pack

z3ntu commented on 2020-12-06 09:28

jellyfin-git now requires .NET 5 to build. At the moment of writing dotnet-core in [community] is still on version 3, so you must install e.g. dotnet-core-bin from the AUR in the meantime.

MrTimscampi commented on 2020-11-28 15:33

@z3ntu: It's mainly to signal that we made some changes that break the build process :) Of course, it's not fixable until the packages get updated, but I figured we should let you and other users know that the package won't work with the current master branch.

z3ntu commented on 2020-11-26 16:35

@MrTimscampi: I'm not sure what you want me to do. I can't make dotnet-core in [community] get updated faster, you can use e.g. https://aur.archlinux.org/pkgbase/dotnet-core-bin/ in the meantime from the AUR.

rustemb commented on 2020-11-05 10:31

missing dep python

gyp ERR! stack Error: Can't find Python executable "python", you can set the PYTHON env variable.

m42uko commented on 2020-03-22 16:38

@z3ntu: Interesting... maybe there's a difference between the x86_64 and the ARM build. I just removed python2 from my system and now the build fails again. The problem seems to lie within the node-gyp dependency. See https://pastebin.com/qFFmZ18k for the full log.

As for dotnet on aarch64, I used the dotnet-core-bin package from the AUR, although the source packages should also work, but need to compiled by hand for AARCH64.

z3ntu commented on 2020-03-22 15:51

@m42uko: I just built the package in a fresh container with only the essentials installed (and definitely no python2) and it builds fine. Also how did you build this on aarch64? I don't see any dotnet* packages on https://archlinuxarm.org/packages

m42uko commented on 2020-03-21 16:45

I just had to install python2 for the build to succeed, so you might want to add it to the dependencies. Also, I can confirm this works on the aarch64 architecture, so you can add it to the arch list if you want.