Package Details: jekyll 4.1.1-1

Git Clone URL: https://aur.archlinux.org/jekyll.git (read-only, click to copy)
Package Base: jekyll
Description: A simple, blog aware, static site generator.
Upstream URL: https://github.com/jekyll/jekyll
Keywords: jekyll ruby
Licenses: MIT
Conflicts: ruby-jekyll
Provides: jekyll=4.1.1, ruby-jekyll
Replaces: ruby-jekyll
Submitter: SilverRainZ
Maintainer: SilverRainZ (bjo, bertptrs)
Last Packager: bertptrs
Votes: 79
Popularity: 2.51
First Submitted: 2017-11-20 05:56
Last Updated: 2020-06-24 17:35

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 11 12 Next › Last »

anatolik commented on 2014-05-14 15:49

> Could not find 'parslet' (~> 1.5.0) - did find: [parslet-1.6.0] (Gem::LoadError)

jekyll depends on parslet-1.5 via ruby-toml. Are you sure you have all your dependencies up-to-date?

bchretien commented on 2014-05-13 09:10

+1 for ruby-celluloid-io. I also had a problem with ruby-parslet:

/usr/lib/ruby/2.1.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'parslet' (~> 1.5.0) - did find: [parslet-1.6.0] (Gem::LoadError)

alexod commented on 2014-05-09 02:01

anatolik thank you.

I noticed that jekyll also requires ruby-celluloid-io (I do not know whether I requires it directly or via some other dependency) and that execjs requires a javascript runtime (that I reported to that package).

anatolik commented on 2014-05-08 16:14

As a workaround install ruby-timers-1 package

anatolik commented on 2014-05-08 15:51

Yes, the problem is with ruby-celluloid package that pulls wrong dependencies. It should be reported there.

alexod commented on 2014-05-08 15:20

After upgrading I get the following error:

/usr/lib/ruby/2.1.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'timers' (~> 1.1.0) - did find: [timers-2.0.0] (Gem::LoadError)
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1295:in `block in activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `each'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1266:in `activate'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1298:in `block in activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `each'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1266:in `activate'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1298:in `block in activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `each'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1266:in `activate'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_gem.rb:54:in `gem'
from /usr/bin/jekyll:22:in `<main>'

It seems that the wrong version of ruby-timers is in aur. Since the dependency on ruby-timer is indirect via ruby-celluloit, this is probably a bug in this package.

anatolik commented on 2013-12-16 07:17

btw I can take this and other your gems. I mostly scripted the gem->arch maintenance tasks.

anatolik commented on 2013-12-16 07:16

The "~>" version restriction does not map to Arch model directly. One needs to use "versioned packages"

https://wiki.archlinux.org/index.php/Ruby_Gem_Package_Guidelines#Versioned_packages

oliparcol commented on 2013-08-18 12:09

thank you, I will take a look

rberaldo commented on 2013-08-14 23:20

This might be of help: https://aur.archlinux.org/packages/pacgem/.