Package Details: jekyll 4.1.0-2

Git Clone URL: https://aur.archlinux.org/jekyll.git (read-only, click to copy)
Package Base: jekyll
Description: A simple, blog aware, static site generator.
Upstream URL: https://github.com/jekyll/jekyll
Keywords: jekyll ruby
Licenses: MIT
Conflicts: ruby-jekyll
Provides: jekyll=4.1.0, ruby-jekyll
Replaces: ruby-jekyll
Submitter: SilverRainZ
Maintainer: SilverRainZ (bjo, bertptrs)
Last Packager: bertptrs
Votes: 76
Popularity: 0.79
First Submitted: 2017-11-20 05:56
Last Updated: 2020-05-27 16:12

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

CarstenF commented on 2016-01-27 10:06

The Update of the Package is WIP. But I can not upload it. If I find the Problem I will push the Update

kseistrup commented on 2015-12-23 10:09

The official version is now 3.0.1. Could the maintainer please update this package? Cheers.

WhyNotHugo commented on 2015-08-24 23:03

Manually maintaining a pile of ruby-* packages is a PITA. I recently discovered an Arch repo that contains binary packages for these, automatically generated, and maintained by one of the Arch devs (so we might as well trust it).

I recommend that you prefer it instead of using the AUR:

https://github.com/anatol/quarry

I'll be orphaning this now, so feel free to pick it up if you don't care much about my above advise.

Note that I've updated jekyll and all it's dependencies too, so it's safe to keep using this anyway.

WhyNotHugo commented on 2015-08-24 22:45

I uninstalled every single ruby package and reinstalled them. Looks like jekyll-sass was missing from the dependency tree.

kitarek commented on 2015-08-24 19:37

@hobarrera - Thanks very much. `jekyll serve` is still reporting for me missing `RedCloth-4.2.9` dependency.

I'm not sure if it's related to some packages not rebuilt today on my side. I have rebuilt `rebu-jekyll` (and its new deps) as well as `ruby-jekyll-watch` (deps: -listen).

Thanks a lot!

WhyNotHugo commented on 2015-08-24 17:39

I've updated this package and several of its dependencies.

Thanks for all the detailed messages. I hope I didn't miss uploading anything (it's kinda hard to keep track of what's uploaded and what's not).

mschu commented on 2015-08-17 23:13

celluloid needs to be version 16 as well: https://talk.jekyllrb.com/t/error-while-trying-to-run-jekyll-serve/933/8

sorry for spamming you so much, let me know if you need help fixing the deps :-)

mschu commented on 2015-08-17 23:05

And further celluloid, rspec-logsplit, hitimes, timers, celluloid-extras, celluloid-fsm, celluloid-pool, celluloid-supervision, celluloid-essentials, bundler, nenv, dotenv, rb-fsevent, ffi, rb-inotify.

And community/nodejs or another JS framework as ItachiSan pointed out.

mschu commented on 2015-08-17 22:51

I still get an error message when running Jekyll in my page directory:

/usr/lib/ruby/2.2.0/rubygems/dependency.rb:315:in `to_specs': Could not find 'jekyll-sass-converter' (~> 1.0) among 30 total gem(s) (Gem::LoadError)

Seems to need a depends on ruby-jekyll-sass-converter. And ruby-jekyll-watch, which is missing ruby-listen (there is already a comment on the package).

WhyNotHugo commented on 2015-08-14 02:20

Just pushed ruby-kramdown. Thanks for the heads up.