Package Details: jekyll 4.1.0-2

Git Clone URL: https://aur.archlinux.org/jekyll.git (read-only, click to copy)
Package Base: jekyll
Description: A simple, blog aware, static site generator.
Upstream URL: https://github.com/jekyll/jekyll
Keywords: jekyll ruby
Licenses: MIT
Conflicts: ruby-jekyll
Provides: jekyll=4.1.0, ruby-jekyll
Replaces: ruby-jekyll
Submitter: SilverRainZ
Maintainer: SilverRainZ (bjo, bertptrs)
Last Packager: bertptrs
Votes: 76
Popularity: 0.81
First Submitted: 2017-11-20 05:56
Last Updated: 2020-05-27 16:12

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

SilverRainZ commented on 2017-11-21 04:41

Hi patrick.luehne

> but the dependency to ruby-rouge can’t be found when attempting to build Jekyll without any Ruby dependencies installed

Yes, I reproduced it. There is three version of rough on AUR & community: community/ruby-rouge 3.0.0-1, aur/ruby-rouge-1 1.11.1-2 and aur/ruby-rouge-2.0 2.0.7-2, the last one package actually meet the requirement 1.7 <= ruby-rouge < 3, I don't know while my aur helper(yaourt) can not find the dependency :-(.

> The official gemspec file shows that ruby-rouge >= 1.7 and < 4 is okay

Here is 3.6.2 but not git master, so I think we should follow jekyll's page[1] on rubygems.org?

[1] https://rubygems.org/gems/jekyll/versions/3.6.2

patrick.luehne commented on 2017-11-20 17:42

@SilverRainZ: Thanks for taking over :)! You’re probably already aware of this, but the dependency to ruby-rouge can’t be found when attempting to build Jekyll without any Ruby dependencies installed. Should we create a new ruby-rouge (without version number suffix in the name) package for that?

Also, I think that the dependency to ruby-rouge < 3 isn’t needed. The official gemspec file shows that ruby-rouge >= 1.7 and < 4 is okay [1], if I read that correctly.




[1] https://github.com/jekyll/jekyll/blob/master/jekyll.gemspec#L42-L43

patrick.luehne commented on 2017-11-17 14:07

Aside from the fact that this PKGBUILD is still broken, I believe that the package name should be “jekyll” and not “ruby-jekyll,” according to the Arch Ruby Gem packaging guidelines [1]. The prefix “ruby-” appears to be used only for libraries and not applications such as Jekyll.




[1] https://wiki.archlinux.org/index.php/Ruby_Gem_package_guidelines#Package_naming

SilverRainZ commented on 2017-11-10 03:04

Please don't update the version without fix dependencies.
This package is still *BROKEN*.

patrick.luehne commented on 2017-10-10 22:30

Please fix the dependency to liquid ≥ 4.0.0 in the PKGBUILD.

Concerning the Liquid dependency, I added an AUR package called ruby-liquid containing the required version (4.0.0).

I believe the dependencies should now read:

depends=('ruby' 'ruby-addressable>=2.4' 'ruby-colorator>=1.0' 'ruby-jekyll-sass-converter>=1.0' 'ruby-jekyll-watch>=1.1' 'ruby-kramdown>=1.14' 'ruby-liquid>=4.0' 'ruby-mercenary>=0.3.3' 'ruby-pathutil>=0.9' 'ruby-rouge-2.0' 'ruby-safe_yaml>=1.0')

Let me know if I can be of any help :). Thanks!

patrick.luehne commented on 2017-10-03 23:17

Dear maintainers,

Jekyll as of version 3.6.0 has multiple dependencies that are currently not met by this package [1].

The following dependencies are missing or outdated:

* ruby-kramdown (1.14 required but only 1.10 in the AUR, I already contacted the maintainers)
* ruby-liquid (4.0 required but only 3.0.6 in the AUR, a new package might be necessary)

I suggest adding the required minimal versions to the PKGBUILD dependencies exactly as listed in the gemspec [1]. Concerning liquid 4, I’m not sure whether it should be a package separate from ruby-liquid-3, or whether there should be only one ruby-liquid package at some point. What do you think?

Best wishes,
Patrick




[1] https://github.com/jekyll/jekyll/blob/master/jekyll.gemspec#L33-L43

jplatte commented on 2017-09-21 18:04

Yes, the 'jekyll new' template uses bundler to install the minima theme. But jekyll can be used without themes nevertheless.

yair commented on 2017-09-21 12:19

seems bundler is a requirement, also mentioned in the jekyll quick start page

```➜ jekyll new blog
Dependency Error: Yikes! It looks like you don't have bundler or one of its dependencies installed. In order to use Jekyll as currently configured, you'll need to install this gem.
```

jplatte commented on 2017-08-29 16:25

ber532k: Are you using a theme / plugin? I think jekyll uses bundler to download (and build?) themes and/or plugins. But I'm pretty sure that it's not a hard dependency.

seifferth commented on 2017-08-29 10:47

I just had an issue after installing this package via pacaur. Something about bundler-something not found. Installing ruby-bundler from community (and reinstalling ruby-jekyll) apparently fixed that, so you might consider adding ruby-bundler as a dependency.