Package Details: jekyll 4.1.1-1

Git Clone URL: https://aur.archlinux.org/jekyll.git (read-only, click to copy)
Package Base: jekyll
Description: A simple, blog aware, static site generator.
Upstream URL: https://github.com/jekyll/jekyll
Keywords: jekyll ruby
Licenses: MIT
Conflicts: ruby-jekyll
Provides: jekyll=4.1.1, ruby-jekyll
Replaces: ruby-jekyll
Submitter: SilverRainZ
Maintainer: SilverRainZ (bjo, bertptrs)
Last Packager: bertptrs
Votes: 79
Popularity: 2.56
First Submitted: 2017-11-20 05:56
Last Updated: 2020-06-24 17:35

Latest Comments

« First ‹ Previous ... 6 7 8 9 10 11 12 Next › Last »

oliparcol commented on 2013-01-19 12:58

I just updated ruby-jekyll to the latest version.

Please note: due to this bug (https://github.com/mojombo/jekyll/issues/734#issue-ref-33517105), the ruby-kramdown version needs to be included between 0.13.4 and 0.13.7

oliparcol commented on 2012-10-19 10:09

The new version include the LICENSE file to avoid any resolution problem in github.

oliparcol commented on 2012-10-04 08:34

you're right, I will include the LICENCE file in the AUR package

srl commented on 2012-10-04 07:59

==> Retrieving Sources...
-> Found jekyll-0.11.2.gem
-> Found LICENSE
==> Validating source files with md5sums...
jekyll-0.11.2.gem ... Passed
LICENSE ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build ruby-jekyll.

It's probably a bad idea to have the URL be raw/master instead of a specific commit/tag, for this reason.

oliparcol commented on 2012-08-19 09:36

Jekyll now depends on ruby-kramdown instead of ruby-kramdown-last

oliparcol commented on 2011-12-25 11:14

sorry for the delay... latest version of jekyll is 0.11.0, the version used by rack is the 0.6.2 but I suppose it will work with the latest one.

How different versions of jekyll work together, I don't know... I think the best thing to do is either use gem mechanism or AUR but using both might be a bad idea... It's quite easy to build a new AUR package for rack-jekyll which will check for ruby-jekyll dependency in AUR.

For syntax highlighting, the only package which isn't needed is ruby-albino, you can just remove it from the PKGBUILD file if you don't need it.

hendry commented on 2011-12-02 06:01

I don't understand how gems/Arch packages work together.

sudo gem install rack-jekyll, installed:
Successfully installed jekyll-0.6.2
Successfully installed rack-1.2.4
Successfully installed rack-jekyll-0.3.7

How does ruby-jekyll 0.11.0-3 work with "jekyll-0.6.2"?


Another question is if I just want to use markdown with jekyll and no syntax highlighting, why do I have to install all the deps?

oliparcol commented on 2011-07-14 14:17

kramdown version fixed

oliparcol commented on 2011-05-17 14:25

one useless depedency removed

oliparcol commented on 2011-02-21 19:07

done, thanks for the advice!