Package Details: jekyll 4.1.0-2

Git Clone URL: (read-only, click to copy)
Package Base: jekyll
Description: A simple, blog aware, static site generator.
Upstream URL:
Keywords: jekyll ruby
Licenses: MIT
Conflicts: ruby-jekyll
Provides: jekyll=4.1.0, ruby-jekyll
Replaces: ruby-jekyll
Submitter: SilverRainZ
Maintainer: SilverRainZ (bjo, bertptrs)
Last Packager: bertptrs
Votes: 76
Popularity: 0.79
First Submitted: 2017-11-20 05:56
Last Updated: 2020-05-27 16:12

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

tkappe commented on 2018-10-10 10:37

On my machine, Jekyll is broken after the last update. I get the following:

Traceback (most recent call last):
    8: from /usr/bin/jekyll:23:in `<main>'
    7: from /usr/lib/ruby/2.5.0/rubygems.rb:309:in `activate_bin_path'
    6: from /usr/lib/ruby/2.5.0/rubygems.rb:309:in `synchronize'
    5: from /usr/lib/ruby/2.5.0/rubygems.rb:310:in `block in activate_bin_path'
    4: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1443:in `activate'
    3: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1461:in `activate_dependencies'
    2: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1461:in `each'
    1: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1472:in `block in activate_dependencies'
/usr/lib/ruby/2.5.0/rubygems/dependency.rb:313:in `to_specs': Could not find 'i18n' (~> 0.7) - did find: [i18n-1.1.0] (Gem::MissingSpecVersionError)
Checked in 'GEM_PATH=~/.gem/ruby/2.5.0:/usr/lib/ruby/gems/2.5.0', execute `gem env` for more information

Forcing a rebuild of the PKGBUILD did not help.

After some digging, I found that /usr/lib/ruby/gems/2.5.0/specifications/jekyll-3.8.4.gemspec still contains a dependency on i18n version 0.7. Bumping this manually to 1.1.0 solved the issue.

SilverRainZ commented on 2018-10-08 14:42

@bertptrs Updated.

bertptrs commented on 2018-10-04 08:28

This PKGBUILD currently has dependencies that cannot be met. The ruby-i18n package is at version 1.1.0 in AUR but this package requires >= 0.7, < 1.

Upstream appears to have loosened this requirement to >=0.9.5, <2. Could you please update the dependencies accordingly so this package can be installed again?

SilverRainZ commented on 2018-04-19 18:27

Jekyll updated to 3.8.0

SilverRainZ commented on 2018-01-19 05:03

@zertyz, Sorry for misleading, ruby-listen is a AUR package and not yet in [community]. ruby-ruby_dep is a dependency of ruby-listen but ruby-listen does not require it, I have notified the maintainer and add ruby-ruby_dep as jekyll's dependency temporarily.

zertyz commented on 2018-01-18 14:28

Thank you for the package.

could not find ruby-listen in [community]. I'm facing an error after installing and running jekyll:

/usr/lib/ruby/2.5.0/rubygems/dependency.rb:310:in to_specs': Could not find 'ruby_dep' (~> 1.2) among 65 total gem(s) (Gem::MissingSpecError) Checked in 'GEM_PATH=/home/luiz/.gem/ruby/2.5.0:/usr/lib/ruby/gems/2.5.0', executegem env` for more information

Installing the package 'ruby-ruby_dep' from AUR solved the issue. Please, add it as a dependency.

SilverRainZ commented on 2018-01-16 04:06

Jekyll has updated to 3.7.0, User can replace ruby-listen-3-0 with ruby-listen now.

cc @jonathon

SilverRainZ commented on 2018-01-15 05:01

@jonathon, all dependencies has satisfied except ruby-jekyll-watch. I have to wait for the maintainer update to 2.0.0 to let jekyll works.

jonathon commented on 2018-01-14 17:26

It looks like jekyll=3.6.2 has a dep on ruby-listen (< 3.1, ~> 3.0) [1] (though this may be due to another installed gem). This version requirement should be resolvable with an update to jekyll=3.7.0 but the PKGBUILD may still need the dep to be added.


SilverRainZ commented on 2017-11-23 05:47

I have changed the dependency constraint from 1.7 < ruby-rouge < 3 to ruby-rouge-1, now this package can be installed smoothly. But it still doesn't work now.

When you install ruby-jekll-watch from AUR, your aur helper may install a wrong version of ruby-listen (3.1.5) package for you. To let jekyll works, Please remove ruby-listen and install ruby-listen-3-0 (3.0.8) instead.

If you want to get pre-built package of jekyll, please considering use: