Package Details: jekyll 4.1.1-1

Git Clone URL: https://aur.archlinux.org/jekyll.git (read-only, click to copy)
Package Base: jekyll
Description: A simple, blog aware, static site generator.
Upstream URL: https://github.com/jekyll/jekyll
Keywords: jekyll ruby
Licenses: MIT
Conflicts: ruby-jekyll
Provides: jekyll=4.1.1, ruby-jekyll
Replaces: ruby-jekyll
Submitter: SilverRainZ
Maintainer: SilverRainZ (bjo, bertptrs)
Last Packager: bertptrs
Votes: 79
Popularity: 2.36
First Submitted: 2017-11-20 05:56
Last Updated: 2020-06-24 17:35

Latest Comments

1 2 3 4 5 6 ... Next › Last »

ZeroCC commented on 2020-01-26 23:44

ruby-mercenary https://www.archlinux.org/packages/community/any/ruby-mercenary/ has been updated to 0.4.0-1 installing ruby-mercenary (0.4.0-1) breaks dependency 'ruby-mercenary<0.4' required by jekyll

xio commented on 2019-11-23 00:27

Cloning jekyll build files...
Checking jekyll dependencies...
...
could not satisfy dependencies:
unable to satisfy dependency 'ruby-concurrent-ruby' required by ruby-i18n
unable to satisfy dependency 'ruby-i18n>=1' required by jekyll

I suspect someone failed to send the memo that "ruby-concurrent-ruby" got renamed to "ruby-concurrent".

alaskanarcher commented on 2019-11-15 04:42

This package is failing to build due to a dependency conflict. I'm reporting this to the other packages as well.

$ aur sync  jekyll
==> Using [aur] repository
  -> jekyll: (none) -> 4.0.0-1
  -> ruby-em-websocket: (none) -> 0.5.1-2
  -> ruby-http_parser.rb: (none) -> 0.6.0-2
  -> ruby-jekyll-watch: (none) -> 2.2.1-1
  -> ruby-kramdown-parser-gfm: (none) -> 1.1.0-1
  -> ruby-liquid: (none) -> 4.0.3-1
  -> ruby-listen: (none) -> 3.1.5-3
  -> ruby-sassc: (none) -> 2.2.1-1
  -> ruby-terminal-table: (none) -> 1.8.0-3
  -> ruby-unicode-display_width: (none) -> 1.6.0-1
==> Retrieving package files
From https://aur.archlinux.org/ruby-listen
 = [up to date]      master     -> origin/master
From https://aur.archlinux.org/ruby-http_parser.rb
 = [up to date]      master     -> origin/master
From https://aur.archlinux.org/ruby-unicode-display_width
 = [up to date]      master     -> origin/master
From https://aur.archlinux.org/ruby-sassc
 = [up to date]      master     -> origin/master
From https://aur.archlinux.org/ruby-jekyll-watch
 = [up to date]      master     -> origin/master
From https://aur.archlinux.org/ruby-liquid
 = [up to date]      master     -> origin/master
From https://aur.archlinux.org/ruby-em-websocket
 = [up to date]      master     -> origin/master
From https://aur.archlinux.org/ruby-kramdown-parser-gfm
 = [up to date]      master     -> origin/master
From https://aur.archlinux.org/ruby-terminal-table
 = [up to date]      master     -> origin/master
From https://aur.archlinux.org/jekyll
 = [up to date]      master     -> origin/master
Running makepkg --clean --syncdeps
==> Making package: ruby-listen 3.1.5-3 (Thu 14 Nov 2019 07:37:51 PM AKST)
==> Checking runtime dependencies...
==> Installing missing dependencies...
resolving dependencies...
looking for conflicting packages...

Package (2)          New Version  Net Change

aur/ruby-rb-fsevent  0.10.3-1       0.15 MiB
aur/ruby-ruby_dep    1.5.0-4        0.05 MiB

Total Installed Size:  0.20 MiB

:: Proceed with installation? [Y/n] 
(2/2) checking keys in keyring                                                                 [#######################################################] 100%
(2/2) checking package integrity                                                               [#######################################################] 100%
(2/2) loading package files                                                                    [#######################################################] 100%
(2/2) checking for file conflicts                                                              [#######################################################] 100%
error: failed to commit transaction (conflicting files)
/usr/bin/ruby_executable_hooks exists in both 'ruby-rb-fsevent' and 'ruby-ruby_dep'
ruby-rb-fsevent: /usr/bin/ruby_executable_hooks exists in filesystem (owned by ruby-benchmark-ips)
ruby-ruby_dep: /usr/bin/ruby_executable_hooks exists in filesystem (owned by ruby-benchmark-ips)
Errors occurred, no packages were upgraded.
==> ERROR: 'pacman' failed to install missing dependencies.
==> Missing dependencies:
  -> ruby-rb-fsevent>=0.9.3
  -> ruby-ruby_dep>=1.2
==> Checking buildtime dependencies...
==> ERROR: Could not resolve all dependencies.

SilverRainZ commented on 2019-09-23 13:28

Jekyll in [archlinuxcn] has been updated to 4.0.0.

bertptrs commented on 2019-08-15 07:28

A few hours ago, the community repo upgraded jekyll-sass-converter to version 2.0.0. The dependency requirements for this package can now no longer be satisfied.

See: https://git.archlinux.org/svntogit/community.git/log/trunk?h=packages/ruby-jekyll-sass-converter

tmikey commented on 2019-08-05 09:13

The latest version, 3.8.6-1 has a dependency problem. This can be temporarily fixed by manually install public_suffix < 4.0 gem install public_suffix -v 3.1.1

Here is the error message:

/usr/lib/ruby/2.6.0/rubygems/dependency.rb:313:in `to_specs': Could not find 'public_suffix' (>= 2.0.2, < 4.0) - did find: [public_suffix-4.0.0] (Gem::MissingSpecVersionError)

bjo commented on 2019-01-21 15:57

I updated the pkgbuild to 3.8.5 now, but unfortunately it does not work with kramdown 2.0.0. I will take look at it later.

bertptrs commented on 2019-01-21 11:19

The package is has unresolvable dependencies now that ruby-kramdown in the main repos has been updated to 2.0.0. Could you please fix this?

As an aside, version 3.8.5 has been available since november: https://github.com/jekyll/jekyll/releases/tag/v3.8.5

frigaut commented on 2018-11-14 12:18

Hi SilverRainZ. The dependency on the ruby-i18n version does not seem to be fixed. It's still ruby-i18n < 1.0, which makes the install fails.

SilverRainZ commented on 2018-10-18 03:17

@tkappe Sorry for replying so late, I reverted the recent update and added package ruby-i18n-0.9. It should be fixed now.