Package Details: jekyll 4.0.0-1

Git Clone URL: https://aur.archlinux.org/jekyll.git (read-only)
Package Base: jekyll
Description: A simple, blog aware, static site generator.
Upstream URL: https://github.com/jekyll/jekyll
Keywords: jekyll ruby
Licenses: MIT
Conflicts: ruby-jekyll
Provides: jekyll=4.0.0, ruby-jekyll
Replaces: ruby-jekyll
Submitter: SilverRainZ
Maintainer: SilverRainZ (bjo, bertptrs)
Last Packager: bertptrs
Votes: 74
Popularity: 0.40
First Submitted: 2017-11-20 05:56
Last Updated: 2019-09-10 08:47

Latest Comments

1 2 3 4 5 6 ... Next › Last »

SilverRainZ commented on 2019-09-23 13:28

Jekyll in [archlinuxcn] has been updated to 4.0.0.

bertptrs commented on 2019-08-15 07:28

A few hours ago, the community repo upgraded jekyll-sass-converter to version 2.0.0. The dependency requirements for this package can now no longer be satisfied.

See: https://git.archlinux.org/svntogit/community.git/log/trunk?h=packages/ruby-jekyll-sass-converter

tmikey commented on 2019-08-05 09:13

The latest version, 3.8.6-1 has a dependency problem. This can be temporarily fixed by manually install public_suffix < 4.0 gem install public_suffix -v 3.1.1

Here is the error message:

/usr/lib/ruby/2.6.0/rubygems/dependency.rb:313:in `to_specs': Could not find 'public_suffix' (>= 2.0.2, < 4.0) - did find: [public_suffix-4.0.0] (Gem::MissingSpecVersionError)

bjo commented on 2019-01-21 15:57

I updated the pkgbuild to 3.8.5 now, but unfortunately it does not work with kramdown 2.0.0. I will take look at it later.

bertptrs commented on 2019-01-21 11:19

The package is has unresolvable dependencies now that ruby-kramdown in the main repos has been updated to 2.0.0. Could you please fix this?

As an aside, version 3.8.5 has been available since november: https://github.com/jekyll/jekyll/releases/tag/v3.8.5

frigaut commented on 2018-11-14 12:18

Hi SilverRainZ. The dependency on the ruby-i18n version does not seem to be fixed. It's still ruby-i18n < 1.0, which makes the install fails.

SilverRainZ commented on 2018-10-18 03:17

@tkappe Sorry for replying so late, I reverted the recent update and added package ruby-i18n-0.9. It should be fixed now.

tkappe commented on 2018-10-10 10:37

On my machine, Jekyll is broken after the last update. I get the following:

Traceback (most recent call last):
    8: from /usr/bin/jekyll:23:in `<main>'
    7: from /usr/lib/ruby/2.5.0/rubygems.rb:309:in `activate_bin_path'
    6: from /usr/lib/ruby/2.5.0/rubygems.rb:309:in `synchronize'
    5: from /usr/lib/ruby/2.5.0/rubygems.rb:310:in `block in activate_bin_path'
    4: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1443:in `activate'
    3: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1461:in `activate_dependencies'
    2: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1461:in `each'
    1: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1472:in `block in activate_dependencies'
/usr/lib/ruby/2.5.0/rubygems/dependency.rb:313:in `to_specs': Could not find 'i18n' (~> 0.7) - did find: [i18n-1.1.0] (Gem::MissingSpecVersionError)
Checked in 'GEM_PATH=~/.gem/ruby/2.5.0:/usr/lib/ruby/gems/2.5.0', execute `gem env` for more information

Forcing a rebuild of the PKGBUILD did not help.

After some digging, I found that /usr/lib/ruby/gems/2.5.0/specifications/jekyll-3.8.4.gemspec still contains a dependency on i18n version 0.7. Bumping this manually to 1.1.0 solved the issue.

SilverRainZ commented on 2018-10-08 14:42

@bertptrs Updated.

bertptrs commented on 2018-10-04 08:28

This PKGBUILD currently has dependencies that cannot be met. The ruby-i18n package is at version 1.1.0 in AUR but this package requires >= 0.7, < 1.

Upstream appears to have loosened this requirement to >=0.9.5, <2. Could you please update the dependencies accordingly so this package can be installed again?