Package Details: jdk7 7u80-1

Git Clone URL: https://aur.archlinux.org/jdk7.git (read-only, click to copy)
Package Base: jdk7
Description: Oracle Java 7 Development Kit (public release - end of support)
Upstream URL: https://www.oracle.com/technetwork/java/archive-139210.html
Keywords: java-environment-jdk java-openjfx java-runtime-headless-jre java-runtime-jre java-web-start-jre
Licenses: custom:Oracle
Provides: java-environment=7, java-environment-jdk=7, java-openjfx=7, java-runtime=7, java-runtime-headless=7, java-runtime-headless-jre=7, java-runtime-jre=7, java-web-start=7, java-web-start-jre=7
Submitter: joschi
Maintainer: severach
Last Packager: severach
Votes: 135
Popularity: 0.000007
First Submitted: 2013-09-11 18:22
Last Updated: 2020-07-23 00:42

Required by (1000)

Sources (7)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

joschi commented on 2014-09-03 16:58

@Jristz: Please see https://aur.archlinux.org/packages/jdk7-oracle/

Nowaker commented on 2014-09-03 15:38

jdk7-compat will be removed soon. Please use jdk7 package - jdk7 no longer conflicts with other Javas. See https://wiki.archlinux.org/index.php/Java#Switching_between_JVM.

Anonymous comment on 2014-09-03 15:26

Since the java-common now is out in extra is more than recommended update to the new javva guidelines since you know "packages not follow the guideliness will be removed" -AUR home

rafaelff commented on 2014-09-03 12:45

Would you please set the jre7-oracle's and jdk7-oracle's dependencies as 'makedepends' of the package base?

Currently the package base 'java7-oracle' has no dependency, only the packages have it. So, when I was building these two packages using yaourt, Yaourt correctly added 'java-common' to the list of packages to be installed, but in the wrong precedence order: 'jre7-oracle' and 'jdk7-oracle' were installed before 'java-common'. Consequence: 'java-default-runtime' was no found when installed both packages.

While this is not exactly your fault, I believe that by adding the dependencies to pkgbase's "makedepends" you will make sure that the required dependencies of each package built are already installed and available.

justin8 commented on 2014-09-01 15:15

What is the difference between this and the jre7 package?

joschi commented on 2014-09-01 07:14

@frownlee: Argh! Thanks, I've fixed it!

Anonymous comment on 2014-09-01 03:10

Small thing - the jre7 install script calls itself java-9-oracle rather than java-7-oracle.

Thanks for making this package!

joschi commented on 2014-08-31 13:03

@russo79: Please see https://aur.archlinux.org/packages/jdk7-oracle/

russo79 commented on 2014-08-25 08:26

Would be nice if this package was updated according to the new Arch Java guidelines: https://wiki.archlinux.org/index.php/Java

A compatible jdk8 [1] has already been uploaded and can be used as example.

This would remove the need for the jdk7-compat [2] package.

[1] https://aur.archlinux.org/packages/jdk8-oracle/
[2] https://aur.archlinux.org/packages/jdk7-compat/

russo79 commented on 2014-08-25 08:26

Would be nice if this package was updated according to the new Arch Java guidelines: https://wiki.archlinux.org/index.php/Java

[1] A compatible jdk8 has already been uploaded and can be used as example.

This would remove the need for the jdk7-compat [2] package.

[1] https://aur.archlinux.org/packages/jdk8-oracle/
[2] https://aur.archlinux.org/packages/jdk7-compat/