Package Details: jdk7 7u80-1

Git Clone URL: https://aur.archlinux.org/jdk7.git (read-only)
Package Base: jdk7
Description: Oracle Java 7 Development Kit (public release - end of support)
Upstream URL: http://www.oracle.com/technetwork/java/javase/downloads/jdk7-downloads-1880260.html
Keywords: java-environment-jdk java-openjfx java-runtime-headless-jre java-runtime-jre java-web-start-jre
Licenses: custom
Provides: java-environment=7, java-environment-jdk=7, java-openjfx=7, java-runtime=7, java-runtime-headless=7, java-runtime-headless-jre=7, java-runtime-jre=7, java-web-start=7, java-web-start-jre=7
Submitter: joschi
Maintainer: severach
Last Packager: Det
Votes: 136
Popularity: 0.170062
First Submitted: 2013-09-11 18:22
Last Updated: 2017-11-15 21:56

Dependencies (9)

Required by (1000)

Sources (6)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

jfcandidofilho commented on 2015-03-21 00:17

@joschi Oh, it's really OK now. Thanks!

joschi commented on 2015-03-20 08:38

@jfcandidofilho: I have re-downloaded the "jdk-7u76-linux-x64.tar.gz" archive and verified that the checksum is correct. If it fails on your system, check your setup.

jfcandidofilho commented on 2015-03-20 06:19

@joschi,

This proxy-thing (no master here :P) wouldn't be bad in terms of security? Shouldn't it be checked by someone? I'm not amused by the fact the SHA-256 is not correct!

joschi commented on 2015-02-09 20:49

The checksum for jdk-7u76-linux-x64.tar.gz (SHA-256: ce8ff4fed2cd16aea432edf8e94f21ccfe29e9d4a659bbbef3551982769e0c8c) is correct and works for me. You might want to check you downloads. Maybe there's a proxy in between which modifies the archives.

vitoreiji commented on 2015-02-03 17:59

jdk-7u76-linux-x64.tar.gz is not passing the hashsum check, please update.

freswa commented on 2015-01-21 12:02

Please do not update the archlinux-java defaults when upgrading. It should be up to the user to switch the defaults when upgrading.

joschi commented on 2014-12-26 13:41

@Det Thanks! Fixed it.

Det commented on 2014-12-24 15:42

Since makepkg 4.2.0, the DLAGENTS line can't have quotes around "oraclelicense=a":

DLAGENTS=('http::/usr/bin/curl -LC - -b oraclelicense=a -O')

joschi commented on 2014-11-05 21:18

@NullAxis Uninstall any older version of this package (or oracle-java7-jre/oracle-java7-jdk) and then install this package.

Also make sure to read https://www.archlinux.org/news/java-users-manual-intervention-required-before-upgrade/ first if you haven't updated your system in a while.

NullAxis commented on 2014-11-05 21:14

I'm having the same error as @madscience, is there any way to fix this?